天天看點

ACM-數論之 Fibonacci Again——hdu1021Fibonacci Again

這道題,雖然是個水題,但是沒有一個數學公式,

難死了= =!,我暴力了很多遍還是沒有成功,

我知道不能用暴力破解,但實在想不出來有什麼方法,

沒辦法,求助咯,最終才知道有這麼個餘數公式:

(a+b)%3 = (a%3+b%3)%3

有了這個公式,那真是手到擒來了!

這題也展現出ACM與數學那不可分割的關系啊~

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 32807    Accepted Submission(s): 15874

Problem Description There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.

Sample Input

0
1
2
3
4
5
        

Sample Output

no
no
yes
no
no
no
        
#include <iostream>
using namespace std;
int fib[1000001];		
int main()
{
	
	int i,n;

	fib[0]=7,fib[1]=11;
	for(i=2;i<1000001;i++)
		fib[i]=(fib[i-1]%3+fib[i-2]%3)%3;	

	while(cin>>n)
	{
		
		if(fib[n]==0)
			cout<<"yes"<<endl;
		else
			cout<<"no"<<endl;
		
	}
	return 0;
}
           

繼續閱讀