天天看點

ACM-簡單題之As Easy As A+B——hdu1040 ***************************************轉載請注明出處:http://blog.csdn.net/lttree*************************************** As Easy As A+B

***************************************轉載請注明出處:http://blog.csdn.net/lttree***************************************

As Easy As A+B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 35503    Accepted Submission(s): 15331

Problem Description These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.

Give you some integers, your task is to sort these number ascending (升序).

You should know how easy the problem is now!

Good luck!

Input Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in the same line. 

It is guarantied that all integers are in the range of 32-int.

Output For each case, print the sorting result, and one line one case.

Sample Input

2
3 2 1 3
9 1 4 7 2 5 8 3 6 9
        

Sample Output

1 2 3
1 2 3 4 5 6 7 8 9
        

Author lcy  

題目:http://acm.hdu.edu.cn/showproblem.php?pid=1040

做一道簡單題吧,題目也說了,和A+B一樣簡單。

求一些數的升序,就一個排序就可以了,而且資料範圍就1000.

/******************************************* 
******************************************** 
*           Author:Tree                    * 
*    From :  blog.csdn.net/lttree          * 
*      Title : As Easy As A+B              * 
*    Source: hdu 1040                      * 
*      Hint :  簡單題                      * 
******************************************** 
*******************************************/  

#include <stdio.h>
#include <algorithm>
using namespace std;
int a[1005];
int main()
{
	int i,n,t;
	scanf("%d",&t);
	while( t-- )
	{
		scanf("%d",&n);
		for( i=0;i<n;++i )
			scanf("%d",&a[i]);
		sort(a,a+n);
		for( i=0;i<n-1;++i )
			printf("%d ",a[i]);
		printf("%d\n",a[n-1]);
	}
	return 0;
}