天天看點

poj 2409 Let it Bead Polya波利亞定理

Let it Bead

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5054 Accepted: 3362

Description

"Let it Bead" company is located upstairs at 700 Cannery Row in Monterey, CA. As you can deduce from the company name, their business is beads. Their PR department found out that customers are interested in buying colored bracelets. However, over 90 percent of the target audience insists that the bracelets be unique. (Just imagine what happened if two women showed up at the same party wearing identical bracelets!) It's a good thing that bracelets can have different lengths and need not be made of beads of one color. Help the boss estimating maximum profit by calculating how many different bracelets can be produced. 

A bracelet is a ring-like sequence of s beads each of which can have one of c distinct colors. The ring is closed, i.e. has no beginning or end, and has no direction. Assume an unlimited supply of beads of each color. For different values of s and c, calculate the number of different bracelets that can be made.

Input

Every line of the input file defines a test case and contains two integers: the number of available colors c followed by the length of the bracelets s. Input is terminated by c=s=0. Otherwise, both are positive, and, due to technical difficulties in the bracelet-fabrication-machine, cs<=32, i.e. their product does not exceed 32.

Output

poj 2409 Let it Bead Polya波利亞定理

For each test case output on a single line the number of unique bracelets. The figure below shows the 8 different bracelets that can be made with 2 colors and 5 beads.

Sample Input

1 1
2 1
2 2
5 1
2 5
2 6
6 2
0 0
      

Sample Output

1
2
3
5
8
13
21
      

Source

Ulm Local 2000

我是小白,初識Polya定理。

不過看了各種代碼,自己琢磨了半天,似乎有這麼一回事:

對于一個置換

1,2,3,4,...,n

1,2,3,4,...,n

現在進行順時針,或逆時針旋轉(就是把底下一行推進一格或置後一格,再把多出的元素補到空位上)

操作k次,那麼得到的置換群可以表示為循環的個數為gcd(n,k);

現在考慮翻轉操作:

如果n是奇數:那麼循環個數為 (n+1)/2;

如果n是偶數:那麼要循環n次,其中n/2個置換群可以表示為 n/2個循環,還有n/2個可以表示為(n+2)/2個循環。

#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<climits>
#include<queue>
#include<vector>
#include<map>
#include<sstream>
#include<set>
#include<stack>
#include<cctype>
#include<utility>
#pragma comment(linker, "/STACK:102400000,102400000")
#define PI 3.1415926535897932384626
#define eps 1e-10
#define sqr(x) ((x)*(x))
#define FOR0(i,n)  for(int i=0 ;i<(n) ;i++)
#define FOR1(i,n)  for(int i=1 ;i<=(n) ;i++)
#define FORD(i,n)  for(int i=(n) ;i>=0 ;i--)
#define  lson   num<<1,le,mid
#define rson    num<<1|1,mid+1,ri
#define MID   int mid=(le+ri)>>1
#define zero(x)((x>0? x:-x)<1e-15)
#define mk    make_pair
#define _f     first
#define _s     second
using namespace std;
//const int INF=    ;
typedef long long ll;
//const ll inf =1000000000000000;//1e15;
//ifstream fin("input.txt");
//ofstream fout("output.txt");
//fin.close();
//fout.close();
//freopen("a.in","r",stdin);
//freopen("a.out","w",stdout);
const int INF =0x3f3f3f3f;
//const int maxn=    ;
//const int maxm=    ;
//by yskysker123

int n,m;
int main()
{
    while(~scanf("%d%d",&m,&n)&&(m||n))
    {
        int ans=0;
        for(int i=1;i<=n;i++)
        {
            ans+=pow(m,__gcd(i,n));
        }
        if(n&1)
         ans+=n*pow(m,(n+1)/2);
        else
          ans+=n/2*pow(m,n/2)+n/2*pow(m,(n+2)/2);
        ans/=2*n;
        printf("%d\n",ans);

    }



    return 0;
}