天天看點

HDU 1719 Friend(規律)

Problem Description

Friend number are defined recursively as follows.

(1) numbers 1 and 2 are friend number;

(2) if a and b are friend numbers, so is ab+a+b;

(3) only the numbers defined in (1) and (2) are friend number.

Now your task is to judge whether an integer is a friend number.

Input

There are several lines in input, each line has a nunnegative integer a, 0<=a<=2^30.

Output

For the number a on each line of the input, if a is a friend number, output “YES!”, otherwise output “NO!”.

Sample Input

3

13121

12131

Sample Output

YES!

YES!

NO!

1和2 是朋友數

如果a和b是兩個朋友數, 那麼滿足 m = a*b+a+b

同時 m = a*b+a+b –>

m = (a+1)(b+1)-1

–> m+1 = (a+1)(b+1)

所有朋友數都是由 1, 2 演變而來 那麼所有朋友數+1 一定 對 (1+1) 和(2+1) 整除完 得 1 這就是規律

但有個特例就是0 0+1 也滿足條件 但題目要說了 隻有 1 2 所有0需要特判

code:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        if(n==)
        {
            printf("NO!\n");
            continue;
        }
        n++;
        while(n%==)
        {
            n=n/;
        }
        while(n%==)
        {
            n=n/;
        }
        if(n==)
        {
            printf("YES!\n");
        }
        else
        {
            printf("NO!\n");
        }
    }
    return ;
}