天天看點

3070 Fibonacci 矩陣乘法

Fibonacci

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3502 Accepted: 2450

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

3070 Fibonacci 矩陣乘法

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1      

Sample Output

0
34
626
6875      

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

3070 Fibonacci 矩陣乘法

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

3070 Fibonacci 矩陣乘法

.

Source

Stanford Local 2006

#include<stdio.h>

int n;

int a[4],b[4];

const int M=10000;

void cal(int n)

{

    if(n==1||n==0)

    {

        a[3]=1;a[2]=1;a[1]=1;a[0]=0;

        return ;

    }

    if(n&1)

    {

        cal(n/2);

        b[3]=(a[3]*a[3]+a[2]*a[1])%M;

        b[2]=(a[3]*a[2]+a[2]*a[0])%M;

        b[1]=(a[1]*a[3]+a[0]*a[1])%M;

        b[0]=(a[1]*a[2]+a[0]*a[0])%M;

        for(int i=0;i<4;i++)  a[i]=b[i];

        b[3]=(a[3]+a[2])%M;

        b[2]=a[3];

        b[1]=(a[1]+a[0])%M;

        b[0]=a[1];

        for(int i=0;i<4;i++)  a[i]=b[i];

    }

    else

    {

        cal(n/2);

        b[3]=(a[3]*a[3]+a[2]*a[1])%M;

        b[2]=(a[3]*a[2]+a[2]*a[0])%M;

        b[1]=(a[1]*a[3]+a[0]*a[1])%M;

        b[0]=(a[1]*a[2]+a[0]*a[0])%M;

        for(int i=0;i<4;i++)  a[i]=b[i];

    }

}

int main()

{

    while(scanf("%d",&n)!=EOF)

    {

        if(n==-1)  break;

        if(n==0) {printf("0/n");continue;}

        cal(n-1);

        printf("%d/n",a[3]);

    }

    return 0;

}