天天看點

hdoj Calculate S(n) 2114 (數學規律 取餘)Calculate S(n)

Calculate S(n)

Time Limit: 10000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 9401 Accepted Submission(s): 3415

Problem Description Calculate S(n).

S(n)=1 3+2 3 +3 3 +......+n 3 .

Input Each line will contain one integer N(1 < n < 1000000000). Process to end of file.

Output For each case, output the last four dights of S(N) in one line.

Sample Input

1
2
        

Sample Output

0001
0009
  
  
   //S(n)=1^3+2^3+3^3+......+n^3可轉化為S(n)=(1+2+3+......+n)^2;
  
  
   知道這個轉化就簡單了。
  
  
          
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define ll long long
using namespace std;
int main()
{
	ll n;
	while(scanf("%lld",&n)!=EOF)
	{
		ll sum=((n*(n+1)/2%10000)*(n*(n+1)/2%10000))%10000;
		printf("%04lld\n",sum);
	}
	return 0;
}