天天看點

hdu1548 A strange lift _BFS最短路A strange lift

A strange lift

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 25368    Accepted Submission(s): 9133

Problem Description

There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.

Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?

Input

The input consists of several test cases.,Each test case contains two lines.

The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.

A single 0 indicate the end of the input.

Output

For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".

Sample Input

5 1 5 3 3 1 2 5 0

Sample Output

3

//
// Created by Admin on 2017/5/2.
//
#include <cstdio>
#include <queue>
#include <cstring>
using namespace std;

int n,a,b;
int k[210],visit[210];

struct node{
    int x,step;
};

int check(int x){
    if(x<=0||x>n)
        return 1;
    return 0;
}

int BFS(){
    queue<node> que;
    node T,next;
    T.x=a;
    T.step=0;
    visit[a]=1;
    que.push(T);
    while (!que.empty()){
        T=que.front();
        que.pop();
        if(T.x==b)
            return T.step;
        for (int i = -1; i <= 1; i+=2) {
            next=T;
            next.x+=i*k[next.x];
            if(check(next.x)||visit[next.x])
                continue;
            visit[next.x]=1;
            next.step++;
            que.push(next);
        }
    }
    return -1;
}

int main(){
    while(scanf("%d",&n),n){
        scanf("%d%d",&a,&b);
        for (int i = 1; i <= n; ++i)
            scanf("%d",&k[i]);
        memset(visit,0, sizeof(visit));
        printf("%d\n",BFS());
    }
}
           
//
// Created by Admin on 2017/5/3.
//
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

#define INF 0x3f3f3f

int n,a,b;  //n:頂點數  a:起點  b:終點
int step[205][205];  //step[i][j]:從i到j的步數
int visit[205];  //頂點是否使用
int d[205];   //起點出發的最短距離

void Dijkstra(int s){
    int min,pos;
    memset(visit,0, sizeof(visit));
    for (int i = 0; i < n; ++i)
        d[i]=step[s][i];
    d[s]=0;
    visit[s]=1;
    for (int i = 0; i < n-1; ++i) {
        min=INF;
        for (int j = 0; j < n; ++j) {  //從尚未使用過的頂點中選擇一個距離最小的頂點
            if(d[j]<min&&!visit[j]){
                pos=j;
                min=d[j];
            }
        }
        if(min==INF)  //如果min沒有更新,說明所有頂點均已使用
            break;
        visit[pos]=1;
        for (int j = 0; j < n; ++j) {
            if(d[j]>d[pos]+step[pos][j]&&!visit[j])
                d[j]=d[pos]+step[pos][j];
        }
    }
}

int main(){
    int k[205];
    while (scanf("%d",&n),n){
        scanf("%d%d",&a,&b);
        a--;b--;
        for (int i = 0; i < n; ++i)
            for (int j = 0; j < n; ++j)
                step[i][j]=INF;
        for (int i = 0; i < n; ++i) {
            scanf("%d",&k[i]);
            if(i+k[i]<n)
                step[i][i+k[i]]=1;
            if(i-k[i]>=0)
                step[i][i-k[i]]=1;
        }
        Dijkstra(a);
        printf("%d\n",d[b]==INF?-1:d[b]);
    }
    return 0;
}