天天看點

hdu 5119 Happy Matt Friends【dp】Happy Matt Friends

Happy Matt Friends

Time Limit: 6000/6000 MS (Java/Others)    Memory Limit: 510000/510000 K (Java/Others)

Total Submission(s): 3037    Accepted Submission(s): 1197

Problem Description

Matt has N friends. They are playing a game together.

Each of Matt’s friends has a magic number. In the game, Matt selects some (could be zero) of his friends. If the xor (exclusive-or) sum of the selected friends’magic numbers is no less than M , Matt wins.

Matt wants to know the number of ways to win.

Input

The first line contains only one integer T , which indicates the number of test cases.

For each test case, the first line contains two integers N, M (1 ≤ N ≤ 40, 0 ≤ M ≤ 106).

In the second line, there are N integers ki (0 ≤ ki ≤ 106), indicating the i-th friend’s magic number.

Output

For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y indicates the number of ways where Matt can win.

Sample Input

2

3 2

1 2 3

3 3

1 2 3

Sample Output

Case #1: 4

Case #2: 2

Hint

In the first sample, Matt can win by selecting:

friend with number 1 and friend with number 2. The xor sum is 3.

friend with number 1 and friend with number 3. The xor sum is 2.

friend with number 2. The xor sum is 2.

friend with number 3. The xor sum is 3. Hence, the answer is 4.

Source

2014ACM/ICPC亞洲區北京站-重制賽(感謝北師和上交)

題目大意:

一共有N個數,找任意個數的數使其亦或值大于等于m,問一共有多少種可行解。

思路:

1、設定dp【i】【j】表示資料選到第i個數亦或值為j的方案數。

2、

①初始化dp【0】【0】=1;

②那麼不難了解其狀态轉移方程:dp【i】【j】=dp【i-1】【j】+dp【i-1】【j^a[i]】

③表示資料選到第i個數的亦或值為j的方案數可以從不選a【i】這個數以及選擇a【i】這個數的狀态轉移過來。

Ac代碼:

#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
long long int dp[45][(1<<20)];
int a[50];
int main()
{
    int t;
    int kase=0;
    scanf("%d",&t);
    while(t--)
    {
        memset(dp,0,sizeof(dp));
        int n,m;
        scanf("%d%d",&n,&m);
        int maxn=(1<<20);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        dp[0][0]=1;
        for(int i=1;i<=n;i++)
        {
            for(int j=0;j<maxn-5;j++)
            {
                dp[i][j]=dp[i-1][j^a[i]]+dp[i-1][j];
            }
        }
        long long int  output=0;
        for(int i=m;i<maxn+10;i++)output+=dp[n][i];
        printf("Case #%d: ",++kase);
        printf("%I64d\n",output);
    }
}