天天看點

hdu 1078 FatMouse and Cheese【經典記憶化搜尋】 FatMouse and Cheese

FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7299    Accepted Submission(s): 3010

Problem Description FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 

Input There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 

n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 

The input ends with a pair of -1's. 

Output For each test case output in a line the single integer giving the number of blocks of cheese collected. 

Sample Input

3 1

1 2 5

10 11 6

12 12 7

-1 -1

Sample Output

37

Source Zhejiang University Training Contest 2001

記憶化搜尋 :算法上依然是搜尋的流程,但是搜尋到的一些解用動态規劃的那種思想和模式作一些儲存。 一般說來,動态規劃總要周遊所有的狀态,而搜尋可以排除一些無效狀态。 更重要的是搜尋還可以剪枝,可能剪去大量不必要的狀态,是以在空間開銷上往往比動态規劃要低很多。 記憶化算法在求解的時候還是按着自頂向下的順序,但是每求解一個狀态,就将它的解儲存下來, 以後再次遇到這個狀态的時候,就不必重新求解了。 這種方法綜合了搜尋和動态規劃兩方面的優點,因而還是很有實用價值的。 我的第一發記憶化搜尋、經典題。

直接暴力敲的話,如果k比較大,圖也在極限大小的時候,是會逾時的,是以用記憶化搜尋的方法來優化。

AC代碼:

#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
int a[105][105];
int dp[105][105];
int fx[4]={0,0,1,-1};
int fy[4]={1,-1,0,0};
int n,k;
int dfs(int x,int y)
{
    int ans=0;
    if(dp[x][y]==0)
    {
        for(int i=1;i<=k;i++)
        {
            for(int j=0;j<4;j++)
            {
                int xx=x+fx[j]*i;
                int yy=y+fy[j]*i;
                if(xx>=1&&xx<=n&&yy>=1&&yy<=n)
                {
                    if(a[xx][yy]>a[x][y])
                    {
                        ans=max(ans,dfs(xx,yy));
                    }
                }
            }
        }
        dp[x][y]=ans+a[x][y];
    }
    return dp[x][y];
}
int main()
{
    while(~scanf("%d%d",&n,&k))
    {
        if(n<0||k<0)break;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                scanf("%d",&a[i][j]);
            }
        }
        memset(dp,0,sizeof(dp));
        printf("%d\n",dfs(1,1));
    }
}