天天看點

lightoj 1249 Positive Negative Sign (數學計算)

1294 - Positive Negative Sign Time Limit:2000MS      Memory Limit: 32768KB      64bit IO Format: %lld & %llu Submit  Status  Practice  LightOJ 1294

Description

Given two integers: n and m and n is divisible by 2m, you have to write down the first n natural numbers in the following form. At first take first mintegers and make their sign negative, then take next m integers and make their sign positive, the next m integers should have negative signs and continue this procedure until all the n integers have been assigned a sign. For example, let n be 12 and m be 3. Then we have

-1 -2 -3 +4 +5 +6 -7 -8 -9 +10 +11 +12

If n = 4 and m = 1, then we have

-1 +2 -3 +4

Now your task is to find the summation of the numbers considering their signs.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case starts with a line containing two integers: n and m (2 ≤ n ≤ 109, 1 ≤ m). And you can assume that n is divisible by 2*m.

Output

For each case, print the case number and the summation.

Sample Input

2

12 3

4 1

Sample Output

Case 1: 18

Case 2: 2

AC代碼。。。。。

#include<stdio.h>
#include<string.h>
#include<math.h>
int main()
{
	int t;
	int T=1;
	long long n,m;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lld%lld",&n,&m);
		printf("Case %d: %lld\n",T++,n*m/2);
	}
	return 0;
}
           

 //太坑了(讀題不細心),浪費好長時間。。。

當時考試是沒看到n是2*m的倍數,把所有情況都考慮了,送出上以後錯了(沒用long long定義)。又讀了一遍題,才發現題中有這個條件。。。

這是當時的代碼(考慮所有情況)。

#include<stdio.h>
#include<string.h>
#include<math.h>
int main()
{
	int t;
	int T=1;
	long long n,m;
	long long k,kk,k1,sum,num;
	scanf("%d",&t);
	while(t--)
	{
		num=sum=0;
		scanf("%d %d",&n,&m);
		if(n%m==0)
		{
			k=n/m;
			if(k&1)
			{
				kk=(k-1)/2;
				num=-1*(m*(m+1))/2-m*m*kk;
			}
			else
			{
				kk=k/2;
				num=m*m*kk;
			}
		}
		else
		{
			k=n%m;
			kk=(n-k)/m;
			sum=k*(2*n-k+1)/2;
			if(kk&1)
			{
				k1=(kk-1)/2;
				num=-1*(m*(m+1))/2-m*m*k1+sum;				
			}
			else
			{
				k1=kk/2;
				num=m*m*k1-sum;
			}
		}
		printf("Case %d: %lld\n",T++,num);
	}
	return 0;
}