天天看点

hdu 2710 Max Factor Max Factor

Max Factor

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3644    Accepted Submission(s): 1167

Problem Description To improve the organization of his farm, Farmer John labels each of his N (1 <= N <= 5,000) cows with a distinct serial number in the range 1..20,000. Unfortunately, he is unaware that the cows interpret some serial numbers as better than others. In particular, a cow whose serial number has the highest prime factor enjoys the highest social standing among all the other cows.

(Recall that a prime number is just a number that has no divisors except for 1 and itself. The number 7 is prime while the number 6, being divisible by 2 and 3, is not).

Given a set of N (1 <= N <= 5,000) serial numbers in the range 1..20,000, determine the one that has the largest prime factor.

Input * Line 1: A single integer, N

* Lines 2..N+1: The serial numbers to be tested, one per line  

Output * Line 1: The integer with the largest prime factor. If there are more than one, output the one that appears earliest in the input file.  

Sample Input

4
36
38
40
42
        

Sample Output

38
        

  求几个数的最大质因子最大的那个数

#include <iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<math.h>
using namespace std;
int main()
{
     int i,j,a[20001]={0,1};
     for(i=2;i<20001;i++)   //a[t]保存t的最大素因数
     {
        if(a[i]==0)
        {
            for(j=i;j<20001;j+=i)
            {
                a[j]=i;
            }
        }
     }

     int n;
     int Max=0;
     int  x;
     int  ans=0;
     while(scanf("%d",&n)!=EOF)
     {
        ans=0;
        Max=0;
        while(n--)
        {
          scanf("%d",&x);
          if(a[x]>Max)
          {
               Max=a[x];
               ans=x;
          }
        }
        printf("%d\n",ans);
     }

     return 0;
}