天天看点

HDOJ 1092 A+B for Input-Output Practice (IV)(水题)A+B for Input-Output Practice (IV)

A+B for Input-Output Practice (IV)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 76476    Accepted Submission(s): 40937

Problem Description Your task is to Calculate the sum of some integers.

Input Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.

Output For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

Sample Input

4 1 2 3 4
5 1 2 3 4 5
0 
        

Sample Output

10
15
        

Author lcy  

Recommend JGShining   |   We have carefully selected several similar problems for you:   1093  1094  1095  1096  2001

#include<stdio.h>
int main(){
	int n,sum,a;
	while(scanf("%d",&n)&&n){
		sum=0;
		while(n--){
			scanf("%d",&a);
			sum+=a;
		}
		printf("%d\n",sum);
	}
	return 0;
}