天天看点

HDU 1061 JAVA

Problem Description

Given a positive integer N, you should output the most right digit of N^N.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output

For each test case, you should output the rightmost digit of N^N.

Sample Input

2

3

4

Sample Output

7

6

package hlh;

import java.util.Scanner;

public class p1061 {

    // 用来找规律: 1~10:1 4 7 6 5 6 3 6 9 0
    // 用来找规律: 11~20:1 6 3 6 5 6 7 4 9 0 
    // 用来找规律: 21~30:1 4 7 6 5 6 3 6 9 0  
    // 用来找规律: 31~40:1 6 3 6 5 6 7 4 9 0  
    public static void main(String[] args) {
        /*  for(int x=111;x<=120;x++){
                int temp = x%10;
                for(int i=1;i<x;i++){
                    temp = (temp*x%10)%10;
                }
                System.out.print(temp+" ");
            }*/
        Scanner sc = new Scanner(System.in);
        int t=sc.nextInt();
        while(t-->){
            int a [] = {,,,,,,,,,,,,,,,,,,,};
            int x =sc.nextInt();
            x = x%;
            if(x%==){
                System.out.println();
                continue;
            }
            System.out.println(a[x-]);
        }
    }
}