天天看点

HDU 2058 JAVA

Problem Description

Given a sequence 1,2,3,……N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.

Input

Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.

Output

For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.

Sample Input

20 10

50 30

0 0

Sample Output

[1,4]

[10,10]

[4,8]

[6,9]

[9,11]

[30,30]

import java.util.*;

class Main {
    public static void main(String args[]) {
        Scanner cin = new Scanner(System.in);
        while (cin.hasNext()) {
            long n = cin.nextInt();
            long m = cin.nextInt();
            if (n ==  && m == )
                break;
            long d = ;
            for (int i = (int) Math.sqrt( * m); i > ; i--) {
                d = m - (i + i * i) / ;
                if (d % i == )
                    System.out.println("[" + (d / i + ) + "," + (d / i + i)
                            + "]");
            }

            System.out.println();
        }
    }
}