天天看点

HDOJ 1004 Let the Balloon Rise(水题)Let the Balloon Rise

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 89158    Accepted Submission(s): 33749

Problem Description Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0
        

Sample Output

red
pink
        

Author WU, Jiazhi  

Source ZJCPC2004  

Recommend JGShining   |   We have carefully selected several similar problems for you:   1008  1005  1013  1012  1006

要注意到的情况(讨论区粘的):

1.其实大家的写法都没错,通过了给的测试数据,对一个数据等情况也处理得很好,但题目有些不地道啊
2.题目可能有多个答案,那么问题就来了,究竟选取那个答案呢,经测试,我发现它选取的是第一个答案
3.比如说:n=4,red red black black 此时答案是red而不是black(其实这也很自然不是,但要考虑到啊)      

第一次交时超时了,数组改大点就AC了:

#include<stdio.h>
#include<string.h>
int main(){
	char a[1010][16];//数组要开大点 
	int b[1010];
	int n,i,j,k;
	while(scanf("%d",&n)&&n){
		getchar();
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		for(i=0;i<n;i++){
			gets(a[i]);
			for(j=0;j<=i;j++){
				if(strcmp(a[i],a[j])==0) 
					b[j]++;//第一次出现此字符串时的位置加 1,不是输入时的位置 
			}
		}
		k=0;
		for(i=1;i<n;i++)
			if(b[k]<b[i]) k=i;
		puts(a[k]);
	}
	return 0;
}
           

继续阅读