天天看點

HDOJ 1004 Let the Balloon Rise(水題)Let the Balloon Rise

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 89158    Accepted Submission(s): 33749

Problem Description Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0
        

Sample Output

red
pink
        

Author WU, Jiazhi  

Source ZJCPC2004  

Recommend JGShining   |   We have carefully selected several similar problems for you:   1008  1005  1013  1012  1006

要注意到的情況(讨論區粘的):

1.其實大家的寫法都沒錯,通過了給的測試資料,對一個資料等情況也處理得很好,但題目有些不道地啊
2.題目可能有多個答案,那麼問題就來了,究竟選取那個答案呢,經測試,我發現它選取的是第一個答案
3.比如說:n=4,red red black black 此時答案是red而不是black(其實這也很自然不是,但要考慮到啊)      

第一次交時逾時了,數組改大點就AC了:

#include<stdio.h>
#include<string.h>
int main(){
	char a[1010][16];//數組要開大點 
	int b[1010];
	int n,i,j,k;
	while(scanf("%d",&n)&&n){
		getchar();
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		for(i=0;i<n;i++){
			gets(a[i]);
			for(j=0;j<=i;j++){
				if(strcmp(a[i],a[j])==0) 
					b[j]++;//第一次出現此字元串時的位置加 1,不是輸入時的位置 
			}
		}
		k=0;
		for(i=1;i<n;i++)
			if(b[k]<b[i]) k=i;
		puts(a[k]);
	}
	return 0;
}
           

繼續閱讀