天天看点

hdu 1159 Common Subsequence(最长公共子序列) Common Subsequence

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 23761    Accepted Submission(s): 10490

Problem Description A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 

The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 

Sample Input

abcfbc abfcab
programming contest 
abcd mnp
        

Sample Output

4
2
0
        

给出两个序列,求这两个序列的最长公共子序列的长度

#include <iostream>
#include <algorithm>
using namespace std;
const int N=1010;
int dp[N][N];
int main()
{
    string s1,s2;
    while (cin>>s1>>s2)
    {
        long len1,len2;
        len1=s1.size();
        len2=s2.size();
        memset(dp, 0, sizeof(dp));
        for (int i=1; i<=len1; i++)
        {
            for (int j=1; j<=len2; j++)
            {
                if(s1[i-1]==s2[j-1])
                {
                    dp[i][j]=dp[i-1][j-1]+1;
                }
                else
                {
                    dp[i][j]=max(dp[i-1][j], dp[i][j-1]);
                }
            }
        }
        cout<<dp[len1][len2]<<endl;
    }
    return 0;
}
           

输出最长子序列:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
const int N=1010;
int dp[N][N];
char lcs[N];
int flag[N][N];
string s1,s2;
void getlcs(int cnt)
{
    int i=s1.length();
    int j=s2.length();
    while (i&& j)
    {
        if(flag[i][j]==0)
        {
            lcs[--cnt]=s1[i-1];
            i--;
            j--;
        }
        else if(flag[i][j]==1)
            i--;
        else
            j--;
    }
}
int main()
{
    
    while (cin>>s1>>s2)
    {
        long len1,len2;
        len1=s1.size();
        len2=s2.size();
        memset(dp, 0, sizeof(dp));
        for (int i=1; i<=len1; i++)
        {
            for (int j=1; j<=len2; j++)
            {
                if(s1[i-1]==s2[j-1])
                {
                    flag[i][j]=0;
                    dp[i][j]=dp[i-1][j-1]+1;
                }
                else if(dp[i-1][j]>dp[i][j-1])
                {
                    dp[i][j]=dp[i-1][j];
                    flag[i][j]=1;
                }
                else
                {
                    dp[i][j]=dp[i][j-1];
                    flag[i][j]=2;
                }
            }
        }
        cout<<dp[len1][len2]<<endl;
        getlcs(dp[len1][len2]);
        int len=dp[len1][len2];
        lcs[len]='\0';
        cout<<lcs<<endl;
    }
    return 0;
}