天天看点

HDU 5671 Matrix

Problem Description

M that has 

n rows and 

m columns 

(1≤n≤1000,1≤m≤1000).Then we perform 

q(1≤q≤100,000) operations:

1 x y: Swap row x and row y 

(1≤x,y≤n);

2 x y: Swap column x and column y 

(1≤x,y≤m);

3 x y: Add y to all elements in row x 

(1≤x≤n,1≤y≤10,000);

4 x y: Add y to all elements in column x 

(1≤x≤m,1≤y≤10,000);

Input

T(1≤T≤20) indicating the number of test cases. For each test case:

The first line contains three integers 

n, 

m and 

q.

The following 

n lines describe the matrix M.

(1≤Mi,j≤10,000) for all 

(1≤i≤n,1≤j≤m).

The following 

q lines contains three integers 

a(1≤a≤4), 

x and 

y.

Output

M after all 

q

Sample Input

2

3 4 2

1 2 3 4

2 3 4 5

3 4 5 6

1 1 2

3 1 10

2 2 2

1 10

10 1

1 1 2

2 1 2

Sample Output

12 13 14 15

1 2 3 4

3 4 5 6

1 10

10 1

行列分开处理即可。

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long LL;
const int low(int x) { return x&-x; }
const int INF = 0x7FFFFFFF;
const int mod = 1e9 + 7;
const int maxn = 1e5 + 10;
int T, n, m, q, c, x, y;
int f[1005][1005];

struct change 
{
    int x, y;
}a[maxn], b[maxn];

int main()
{
    scanf("%d", &T);
    while (T--)
    {
        scanf("%d%d%d", &n, &m, &q);
        for (int i = 1; i <= n; i++) { a[i].x = i; a[i].y = 0; }
        for (int i = 1; i <= m; i++) { b[i].x = i; b[i].y = 0; }
        for (int i = 1; i <= n; i++)
        {
            for (int j = 1; j <= m; j++)
            {
                scanf("%d", &f[i][j]);
            }
        }
        while (q--)
        {
            scanf("%d%d%d", &c, &x, &y);
            if (c == 1) swap(a[x], a[y]);
            if (c == 2) swap(b[x], b[y]);
            if (c == 3) a[x].y += y;
            if (c == 4) b[x].y += y;
        }
        for (int i = 1; i <= n; i++)
        {
            for (int j = 1; j <= m; j++)
            {
                printf("%d", f[a[i].x][b[j].x] + a[i].y + b[j].y);
                if (j < m) printf(" "); else printf("\n");
            }
        }
    }
    return 0;
}
Close