天天看点

UVA 10344- 23 out of 5

Your task is to write a program that can decide whether you can find an arithmetic expression consisting of five given numbers (1<=i<=5) that will yield the value 23.

For this problem we will only consider arithmetic expressions of the following from:

where : {1,2,3,4,5} -> {1,2,3,4,5} is a bijective function      
and  {+,-,*} (1<=i<=4)      

​​Input​​

The Input consists of 5-Tupels of positive Integers, each between 1 and 50.

Input is terminated by a line containing five zero's. This line should not be processed.

​​Output​​

For each 5-Tupel print "Possible" (without quotes) if their exists an arithmetic expression (as described above) that yields 23. Otherwise print "Impossible".

​​Sample Input​​

1 1 1 1 1      
1 2 3 4 5      
2 3 5 7 11      
0 0 0 0 0      

​​Sample Output​​

Impossible      
Possible      
Possible      
#include<algorithm>
#include<iostream>
#include<stdio.h>
using namespace std;
int a[5], f;

void work()
{
  int b[4];
  for (b[0] = 0; b[0] < 3; b[0]++)
    for (b[1] = 0; b[1] < 3; b[1]++)
      for (b[2] = 0; b[2] < 3; b[2]++)
        for (b[3] = 0; b[3] < 3; b[3]++)
        {
          int sum = a[0];
          for (int i = 0; i < 4; i++){
            if (b[i] == 0) sum += a[i + 1];
            if (b[i] == 1) sum -= a[i + 1];
            if (b[i] == 2) sum *= a[i + 1];
          }
          if (sum == 23) { f = 0; goto end; }
        }
  end:;
}

int main()
{
  while (cin >> a[0] >> a[1] >> a[2] >> a[3] >> a[4], a[0], a[1], a[2], a[3], a[4])
  {
    sort(a, a + 5);   f = 1;    work();
    while (next_permutation(a, a + 5) && f) work();
    if (f) cout << "Impossible" << endl; else cout << "Possible" << endl;
  }
  return 0;
}