天天看點

HDU 5724 Chess

Problem Description

Alice and Bob are playing a special chess game on an n × 20 chessboard. There are several chesses on the chessboard. They can move one chess in one turn. If there are no other chesses on the right adjacent block of the moved chess, move the chess to its right adjacent block. Otherwise, skip over these chesses and move to the right adjacent block of them. Two chesses can’t be placed at one block and no chess can be placed out of the chessboard. When someone can’t move any chess during his/her turn, he/she will lose the game. Alice always take the first turn. Both Alice and Bob will play the game with the best strategy. Alice wants to know if she can win the game.

Input

Multiple test cases.

The first line contains an integer 

T(T≤100), indicates the number of test cases.

For each test case, the first line contains a single integer 

n(n≤1000), the number of lines of chessboard.

Then 

n lines, the first integer of ith line is 

m(m≤20), indicates the number of chesses on the ith line of the chessboard. Then m integers 

pj(1≤pj≤20)followed, the position of each chess.

Output

For each test case, output one line of “YES” if Alice can win the game, “NO” otherwise.

Sample Input

2
1
2 19 20
2
1 19
1 18      

Sample Output

NO

YES

先預處理出2^20次的sg函數,然後直接異或起來即可。

#include<set>
#include<map>
#include<cmath>
#include<stack>
#include<queue>
#include<bitset>
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<functional>
#define rep(i,j,k) for (int i = j; i <= k; i++)
#define per(i,j,k) for (int i = j; i >= k; i--)
using namespace std;
typedef long long LL;
const int low(int x) { return x&-x; }
const int N = 2e6 + 10;
const int mod = 1e9 + 7;
const int INF = 0x7FFFFFFF;
int T, n, m, sg[N], h[20];

int dfs(int x)
{
    rep(i, 0, 19) h[i] = 0;
    per(i, 19, 0)
    {
        if (x&(1 << i))
        {
            int y = x;
            per(j, i - 1, 0)
            {
                if (!((1 << j)&x))
                {
                    y = y ^ (1 << i) ^ (1 << j); break;
                }
            }
            if (y == x) continue;
            h[sg[y]] = 1;
        }
    }
    rep(i, 0, 19) if (!h[i]) return i;
}

int main()
{
    rep(i, 0, (1 << 20) - 1) sg[i] = dfs(i);
    scanf("%d", &T);
    while (T--)
    {
        scanf("%d", &n);
        int flag = 0;
        while (n--)
        {
            scanf("%d", &m);
            int x, y = 0;
            while (m--) scanf("%d", &x), y |= 1 << (20 - x);
            flag ^= sg[y];
        }
        if (flag) printf("YES\n"); else printf("NO\n");
    }
    return 0;
}