天天看點

acm hdu 1908 Double Queue

Problem Description The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing environment provided by IBM Romania, and using modern information technologies. As usual, each client of the bank is identified by a positive integer K and, upon arriving to the bank for some services, he or she receives a positive integer priority P. One of the inventions of the young managers of the bank shocked the software engineer of the serving system. They proposed to break the tradition by sometimes calling the serving desk with the lowest priority instead of that with the highest priority. Thus, the system will receive the following types of request:

Your task is to help the software engineer of the bank by writing a program to implement the requested serving policy.

Input Each line of the input contains one of the possible requests; only the last line contains the stop-request (code 0). You may assume that when there is a request to include a new client in the list (code 1), there is no other request in the list of the same client or with the same priority. An identifier K is always less than 10 6, and a priority P is less than 10 7. The client may arrive for being served multiple times, and each time may obtain a different priority.

Output For each request with code 2 or 3, the program has to print, in a separate line of the standard output, the identifier of the served client. If the request arrives when the waiting list is empty, then the program prints zero (0) to the output.

Sample Input

2
1 20 14
1 30 3
2
1 10 99
3
2
2
0      

Sample Output

0
20
30
10
0      
分析:在我看來這題真的是難在讀懂題意,假如以前沒有做過這類題,那麼你要了解題意就難了……      
或者可以換種說法,它給出的輸出樣例可以看出些東東來,而上面的描述到更是讓人難以了解題意。      
那麼我接下來我就說說這題要我們做什麼~      
通熟的說,每一行都有一個數來告訴我們要做的事情(原文中展現在Each line of the input contains      
one of the possible requests。)。當輸入的第一個為2或3時,就是要就輸出,1時就要們添加      
一個request,要求按照優先級排列(及按照P的大小排序,是以我們很自然的想到map容器,有自動      
排序的功能)。當輸入的時2時輸出優先級最高的鍵值,3時輸出優先級最低的鍵值。      
明白了要做的東西就好下手了,根本不要管他題目怎麼說的了,也就是們隻要知道怎麼對輸入的這些資料      
處理就足夠了~      
#include<iostream>
#include<string>
#include<map>
#include<stdio.h>
using namespace std;

int main()
{
	int n,k,p;
	map<int,int> L;
//	map<int,int>::iterator it;
	while(scanf("%d",&n)&&n!=0)
	{
		if(n==1)
		{		
			scanf("%d%d",&k,&p);
			L[p]=k;	//按優先級自動排序
		}
		else if(n==2)
		{
			if(L.empty())
				cout<<"0"<<endl;
			else
			{
				cout<<L.rbegin()->second<<endl;
				L.erase(L.rbegin()->first);
			}
		}
		else
		{
			cout<<L.begin()->second<<endl;
			L.erase(L.begin());
		}
	}
	return 0;
}