天天看點

POJ2153-Rank List

這陣子真的是忙得透頂,而且這兩天小病了一場,濤哥他們發的題目我也基本都沒看了,現在的狀态就是,他發什麼題目我看什麼題目,有時間就做,連題目水不水都不深究了。

    這道題依舊水,不過有個地方很會黑人,那就是每次的排名是前面的所有科目的分數累加之和。好了,就這樣。

Rank List

Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 7659 Accepted: 2473

Description

Li Ming is a good student. He always asks the teacher about his rank in his class after every exam, which makes the teacher very tired. So the teacher gives him the scores of all the student in his class and asked him to get his rank by himself. However, he has so many classmates, and he can’t know his rank easily. So he tends to you for help, can you help him?

Input

The first line of the input contains an integer N (1 <= N <= 10000), which represents the number of student in Li Ming’s class. Then come N lines. Each line contains a name, which has no more than 30 letters. These names represent all the students in Li Ming’s class and you can assume that the names are different from each other.

In (N+2)-th line, you'll get an integer M (1 <= M <= 50), which represents the number of exams. The following M parts each represent an exam. Each exam has N lines. In each line, there is a positive integer S, which is no more then 100, and a name P, which must occur in the name list described above. It means that in this exam student P gains S scores. It’s confirmed that all the names in the name list will appear in an exam.

Output

The output contains M lines. In the i-th line, you should give the rank of Li Ming after the i-th exam. The rank is decided by the total scores. If Li Ming has the same score with others, he will always in front of others in the rank list.

Sample Input

3 Li Ming A B 2 49 Li Ming 49 A 48 B 80 A 85 B 83 Li Ming      

Sample Output

1 2      
最近真的好累,代碼也都沒有優化,将就着看吧。      
#include<iostream>
#include<string>
#include<cstring>
#include<cstdio>
#include<map>
using namespace std;

map<string, int>students;
map<string, int>::iterator iter = students.begin();

int main()
{
	int count;
	int lesson;
	char name[35];
	int grade[10005] = {0};
	int id;
	int rank;
	int tot;

	cin >> count;
	getchar();
	for(int i = 1; i <= count; i++)
	{
		gets(name);
		students[name] = i;
	}

	cin >> lesson;
	for(int i = 1; i <= lesson; i++)
	{
		rank = 1;
		for(int m = 1; m <= count; m++)
		{
			cin >> tot;
			getchar();
			gets(name);
			iter = students.find(name);
			id = iter->second;
			grade[id] = grade[id] + tot;
		}
		
		iter = students.find("Li Ming");
		id = iter->second;
		
		for(int i = 1; i <=count; i++)
		{
			if(grade[i] > grade[id])
				rank++;
		}
		cout << rank << endl;
	}

	return 0;
}