天天看点

POJ2153-Rank List

这阵子真的是忙得透顶,而且这两天小病了一场,涛哥他们发的题目我也基本都没看了,现在的状态就是,他发什么题目我看什么题目,有时间就做,连题目水不水都不深究了。

    这道题依旧水,不过有个地方很会黑人,那就是每次的排名是前面的所有科目的分数累加之和。好了,就这样。

Rank List

Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 7659 Accepted: 2473

Description

Li Ming is a good student. He always asks the teacher about his rank in his class after every exam, which makes the teacher very tired. So the teacher gives him the scores of all the student in his class and asked him to get his rank by himself. However, he has so many classmates, and he can’t know his rank easily. So he tends to you for help, can you help him?

Input

The first line of the input contains an integer N (1 <= N <= 10000), which represents the number of student in Li Ming’s class. Then come N lines. Each line contains a name, which has no more than 30 letters. These names represent all the students in Li Ming’s class and you can assume that the names are different from each other.

In (N+2)-th line, you'll get an integer M (1 <= M <= 50), which represents the number of exams. The following M parts each represent an exam. Each exam has N lines. In each line, there is a positive integer S, which is no more then 100, and a name P, which must occur in the name list described above. It means that in this exam student P gains S scores. It’s confirmed that all the names in the name list will appear in an exam.

Output

The output contains M lines. In the i-th line, you should give the rank of Li Ming after the i-th exam. The rank is decided by the total scores. If Li Ming has the same score with others, he will always in front of others in the rank list.

Sample Input

3 Li Ming A B 2 49 Li Ming 49 A 48 B 80 A 85 B 83 Li Ming      

Sample Output

1 2      
最近真的好累,代码也都没有优化,将就着看吧。      
#include<iostream>
#include<string>
#include<cstring>
#include<cstdio>
#include<map>
using namespace std;

map<string, int>students;
map<string, int>::iterator iter = students.begin();

int main()
{
	int count;
	int lesson;
	char name[35];
	int grade[10005] = {0};
	int id;
	int rank;
	int tot;

	cin >> count;
	getchar();
	for(int i = 1; i <= count; i++)
	{
		gets(name);
		students[name] = i;
	}

	cin >> lesson;
	for(int i = 1; i <= lesson; i++)
	{
		rank = 1;
		for(int m = 1; m <= count; m++)
		{
			cin >> tot;
			getchar();
			gets(name);
			iter = students.find(name);
			id = iter->second;
			grade[id] = grade[id] + tot;
		}
		
		iter = students.find("Li Ming");
		id = iter->second;
		
		for(int i = 1; i <=count; i++)
		{
			if(grade[i] > grade[id])
				rank++;
		}
		cout << rank << endl;
	}

	return 0;
}