天天看點

HDU1075(What Are You Talking About)

What Are You Talking About

Problem Description

Ignatius is so lucky that he met a Martian yesterday. But he didn’t know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?

Input

The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string “START”, this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian’s language. A line with a single string “END” indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string “START”, this string should be ignored, then an article written in Martian’s language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can’t find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(’ ‘), tab(’\t’), enter(’\n’) and all the punctuation should not be translated. A line with a single string “END” indicates the end of the book part, and that’s also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.

Output

In this problem, you have to output the translation of the history book.

Sample Input

START

from fiwo

hello difh

mars riwosf

earth fnnvk

like fiiwj

END

START

difh, i’m fiwo riwosf.

i fiiwj fnnvk!

END

Sample Output

hello, i’m from mars.

i like earth!

思路

map一時爽,一直map一直爽。無奈在練習字典樹隻能硬着頭皮寫字典樹了,不過字典樹的複雜度比map要好一點。

  1. 字典樹做法就是存入火星文,然後該火星文會獲得一個根值,然後把英文存入這個根值下。這樣做的好處就是便于以後快速找到。

    這題唯一的缺點就是不說清楚具體的幾個重要參數,導緻字典樹唯一的不好之處就是數組空間大小隻能猜,猜的好AC猜不好不是RE就是TLE(杭電評測系統有時候越界就是給報TLE不給報RE的,刷圖論的時候被上了幾課之後的感悟)。

//字典樹  546ms
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <map> 
using namespace std; 
const int maxn = 1000050;
int trie[maxn][27];
char str[500005][20];
int num[maxn];
int cnt,tot;
void insert(char *s)
{
	int n = strlen(s);
	int root = 0;
	for(int i = 0;i < n;i++){
		int k = s[i] - 'a';
		if(!trie[root][k]){
			trie[root][k] = ++cnt;
		}
		root = trie[root][k];
	}
	num[root] = ++tot;
}
int find_s(char *s)
{
	int n = strlen(s);
	int root = 0;
	for(int i = 0;i < n;i++){
		int k = s[i] - 'a';
		if(!trie[root][k]){
			return -1;
		}
		root = trie[root][k];
	}
	return num[root];
}
int main()
{
	memset(trie,0,sizeof(trie));
	memset(num,-1,sizeof(num));
	cnt = tot = 0;
	char start[15];
	scanf("%s",start);
	char s[10005],p[10005];
	while(~scanf("%s",s)){
		if(strcmp(s,"END") == 0)	break;
		scanf("%s",p);
		insert(p);
		strcpy(str[tot],s);				//存入這個根植下
	}
	scanf("%s",start);
	getchar();
	while(gets(s)){
		if(strcmp(s,"END") == 0)	break;
		int n = strlen(s);
		int res = 0,flag = 0;
		for(int i = 0;i < n;i++){
			if(s[i] >= 'a' && s[i] <= 'z'){
				p[res++] = s[i];
				if(s[i+1] == '\0'){			//最後一個字元可能就是字母,不特判這一串字元串會忽略。
					p[res] = '\0';			
					int ans = find_s(p);
					if(ans == -1){
						printf("%s",p);
					}
					else{
						printf("%s",str[ans]);
					}
				}
				flag = 1;
			}
			else{
				if(flag == 1){
					p[res] = '\0';
					int ans = find_s(p);				//查找
					if(ans == -1){
						printf("%s",p);
					}
					else{
						printf("%s",str[ans]);
					}
					res = 0;flag = 0;
				}
				printf("%c",s[i]);					//其他字元正常輸出。
			}
		}
		printf("\n");
	}	
	return 0;
}
           
  1. map做法就舒服了,比較輕松的做出來。無腦映射就好,但凡會一點STL都能寫出來
//map  889ms
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <map> 
using namespace std;
map<string,string>m; 
int main()
{
	char start[15];
	m.clear();
	map<string,string>::iterator it;
	scanf("%s",start);
	char s[10005],p[10005];
	while(~scanf("%s",s)){
		if(strcmp(s,"END") == 0)	break;
		scanf("%s",p);
		m[p] = s;
	}
	scanf("%s",start);
	getchar();
	while(gets(s)){
		if(strcmp(s,"END") == 0)	break;
		int n = strlen(s);
		int res = 0,flag = 0;
		for(int i = 0;i < n;i++){
			if(s[i] >= 'a' && s[i] <= 'z'){
				p[res++] = s[i];
				if(s[i+1] == '\0'){
					p[res] = '\0';
					it = m.find(p);
					if(it == m.end()){
						printf("%s",p);
					}
					else{
						cout << it->second ;	//這裡隻能cout輸出,printf報錯也不知道為什麼。
					} 
				}
				flag = 1;
			}
			else{
				if(flag == 1){
					p[res] = '\0';
					it = m.find(p);
					if(it == m.end()){
						printf("%s",p);
					}
					else{
						cout << it->second ;
					} 
					res = 0;flag = 0;
				}
				printf("%c",s[i]);
			}
		}
		printf("\n");
	}	
	return 0;
}
           

願你走出半生,歸來仍是少年~