天天看點

hdu3709——Balanced Number

Problem Description A balanced number is a non-negative integer that can be balanced if a pivot is placed at some digit. More specifically, imagine each digit as a box with weight indicated by the digit. When a pivot is placed at some digit of the number, the distance from a digit to the pivot is the offset between it and the pivot. Then the torques of left part and right part can be calculated. It is balanced if they are the same. A balanced number must be balanced with the pivot at some of its digits. For example, 4139 is a balanced number with pivot fixed at 3. The torqueses are 4*2 + 1*1 = 9 and 9*1 = 9, for left part and right part, respectively. It‘s your job

to calculate the number of balanced numbers in a given range [x, y].  

Input The input contains multiple test cases. The first line is the total number of cases T (0 < T ≤ 30). For each case, there are two integers separated by a space in a line, x and y. (0 ≤ x ≤ y ≤ 10 18).  

Output For each case, print the number of balanced numbers in the range [x, y] in a line.  

Sample Input

2
0 9
7604 24324
        

Sample Output

10
897
  
  

        
/**
hdu 3709   數位dp(自身平衡的數字)
題目大意:求給定區間内滿足自身平衡的數的個數,所謂平衡,
          比如:4139 is a balanced number with pivot fixed at 3. The torqueses are 4*2 + 1*1 = 9 and 9*1 = 9, for left part and right part, respectively.
解題思路:枚舉支點。dp[i][j][k] i表示處理到的數位,j是支點,k是力矩和。但是要要把全是0的數排除

*/






#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <cmath>
#include <algorithm>
#include <vector>
#include <map>
#include <string>
#include <stack>
using namespace std;
typedef long long ll;
#define PI 3.1415926535897932
#define E 2.718281828459045
#define INF 0x3f3f3f3f
#define mod 100000007




const int M=1005;
int n,m;
int cnt;
int sx,sy,sz;
int mp[1000][1000];
int pa[M*10],rankk[M];
int head[M*6],vis[M*100];
int dis[M*100];
ll prime[M*1000];
bool isprime[M*1000];
int lowcost[M],closet[M];
char st1[5050],st2[5050];
int len[M*6];
typedef pair<int ,int> ac;
//vector<int> g[M*10];
ll dp[50][50][2000];
int has[10500];
int month[13]= {0,31,59,90,120,151,181,212,243,273,304,334,0};
int dir[8][2]= {{0,1},{0,-1},{-1,0},{1,0},{1,1},{1,-1},{-1,1},{-1,-1}};
void getpri()
{
    ll i;
    int j;
    cnt=0;
    memset(isprime,false,sizeof(isprime));
    for(i=2; i<1000000LL; i++)
    {
        if(!isprime[i])prime[cnt++]=i;
        for(j=0; j<cnt&&prime[j]*i<1000000LL; j++)
        {
            isprime[i*prime[j]]=1;
            if(i%prime[j]==0)break;
        }
    }
}
struct node
{
    int v,w;
    node(int vv,int ww)
    {
        v=vv;
        w=ww;
    }
};
vector<int> g[M*100];
string str[1000];
int bit[50];
ll dfs(int cur,int s,int presum,int e,int z){//presum為左右兩邊力矩和(一邊正一邊負),若為0,則表示平衡
    if(cur<0) return presum==0;
    if(presum<0)return 0;//力矩和為負,則後面的必然小于0  剪枝
    if(!e&&!z&&dp[cur][s][presum]!=-1) return dp[cur][s][presum];
    int endx=e?bit[cur]:9;
    ll ans=0;
    for(int i=0;i<=endx;i++){
        if(z&&!i) ans+=dfs(cur-1,s,presum,e&&i==endx,1);//s是支點,整個dfs過程中不變
        else ans+=dfs(cur-1,s,presum+(cur-s)*i,e&&i==endx,0);
    }
    if(!e&&!z) dp[cur][s][presum]=ans;
    return ans;
}


ll solve(ll n){
    int len=0;
    while(n){
        bit[len++]=n%10;
        n/=10;
    }
    ll ans=0;
    for(int i=0;i<len;i++){
        ans+=dfs(len-1,i,0,1,1);//以i為支點的len位平衡數個數
    }
    return ans-(len-1);//len位的數,有可能是全0,是以隻需保留一個0,剩下的如00,000,000,。。。都不滿足條件
}
int main()
{
    int i,j,k,t;
    ll l,r;
    memset(dp,-1,sizeof(dp));
    scanf("%d",&t);
    while(t--)
    {
        //memset(dight,0,sizeof(dight));
        scanf("%I64d%I64d",&l,&r);
        printf("%I64d\n",solve(r)-solve(l-1));
    }
    return 0;
}