天天看點

[動态規劃][樹形dp]Anniversary party

Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form: 

L K 

It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 

0 0 

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0
      

Sample Output

5

思路:樹形dp;定義狀态dp[i][0]表示編号為i的員工不來時,以他為根的子樹所能獲得的最大rating和;dp[i][1]表示編号為i的員工來時,以他為根的子樹所能獲得的最大rating和;
狀态轉移方程為dp[i][0]=sum{max(dp[j][0],dp[j][1]),j為i的直接下屬},dp[i][1]=rating[i]+sum{dp[j][0],j為i的直接下屬};
AC代碼:      
#include <iostream>
#include <cstdio>
using namespace std;

int dp[6010][2];
int fa[6010];
int n;

void dfs(int root){
   for(int i=1;i<=n;i++){
      if(i==root) continue;
      if(fa[i]==root) {
        dfs(i);
        dp[root][1]+=dp[i][0];
        dp[root][0]+=max(dp[i][1],dp[i][0]);
      }
   }
}

int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++) fa[i]=i,scanf("%d",&dp[i][1]);
    int x,y;
    while(scanf("%d%d",&x,&y)&&(x||y)) fa[x]=y;
    int root=1;
    while(fa[root]!=root) root=fa[root];//找到整棵樹的根節點
    dfs(root);
    printf("%d\n",max(dp[root][0],dp[root][1]));
    return 0;
}      

轉載于:https://www.cnblogs.com/lllxq/p/9398080.html