天天看點

F - Common Subsequence (DP最長公共子序列)

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Input

abcfbc abfcab
programming contest 
abcd mnp      

Output

4
2
0      

Sample Input

abcfbc abfcab
programming contest 
abcd mnp      

Sample Output

4
2
0      

代碼:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cctype> 
#include<algorithm>
using namespace std;
const int N=1e3+5;

char a[N],b[N];
int dp[N][N];

int main(void)
{
	int x,y;
	while(~scanf("%s %s",a+1,b+1))
	{
		x=strlen(a+1);
		y=strlen(b+1);
		int i,j;
		memset(dp,0,sizeof(dp));
		for(i=0;i<=x;i++)
		{
			for(j=0;j<=y;j++)
			{
                                //DP核心
				if(i==0||j==0)
				dp[i][j]=0;
				else if(a[i]==b[j])
				{
					dp[i][j]=dp[i-1][j-1]+1;
				}
				else
				dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
			}
		}
		printf("%d\n",dp[x][y]);
	}
	return 0;
}