天天看点

PAT (Advanced Level) Practise 1033 To Fill or Not to Fill (25)

1033. To Fill or Not to Fill (25)

时间限制

10 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

ZHANG, Guochuan

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive numbers: Cmax (<= 100), the maximum capacity of the tank; D (<=30000), the distance between Hangzhou and the destination city; Davg (<=20), the average distance per unit gas that the car can run; and N (<= 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: Pi, the unit gas price, and Di (<=D), the distance between this station and Hangzhou, for i=1,...N. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print "The maximum travel distance = X" where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

Sample Input 1:

50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300      

Sample Output 1:

749.17      

Sample Input 2:

50 1300 12 2
7.10 0
7.00 600      

Sample Output 2:

The maximum travel distance = 1200.00      

贪心,从一个站点出发,如果能到达油价低于这个站点的站点的话,一定会去第一个。

如果没有,那么在该站点加满油,然后去到能到站点中油价最低的那个。如果还没有,

记录跑的最远的距离。

#include<cstdio>
#include<vector>
#include<map>
#include<queue>
#include<string>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int INF = 0x7FFFFFFF;
const int maxn = 5e2 + 10;
int n;
double C, D, d, maxdis, mincost = INF;

struct point
{
  double p, d;
  void read(){ scanf("%lf%lf", &p, &d); }
  bool operator<(const point&a)const{ return d == a.d ? p < a.p : d < a.d; }
}a[maxn];

void dfs(int x, double cost, double rest)
{
  maxdis = max(maxdis, a[x].d + C*d);
  int minx = x;
  for (int i = x + 1; i < n; i++)
  {
    if (a[i].d - a[x].d <= C*d)
    {
      if (a[i].p <= a[x].p) { 
        double k = (a[i].d - a[x].d) / d;
        if (k > rest) dfs(i, cost + (k - rest)*a[x].p, 0);
        else dfs(i, cost, rest - k);    return; 
      }
      if (minx == x || a[i].p < a[minx].p) minx = i;
    }
  }
  if (a[x].d + C*d >= D)
  {
    if ((D - a[x].d) / d - rest >= 0) 
      mincost = min(mincost, cost + ((D - a[x].d) / d - rest)*a[x].p);
  }
  if (minx > x)
  {
    double k = (C - rest)*a[x].p;
    dfs(minx, cost + k, C - (a[minx].d - a[x].d) / d);
  }
}

int main()
{
  scanf("%lf%lf%lf%d", &C, &D, &d, &n);
  for (int i = 0; i < n; i++) a[i].read();
  sort(a, a + n);
  if (a[0].d > 0) { printf("The maximum travel distance = 0.00\n"); return 0; }
  dfs(0, 0, 0);
  if (maxdis < D) printf("The maximum travel distance = %.2lf\n", maxdis);
  else printf("%.2lf\n", mincost);
  return 0;
}