天天看点

HDU1003`Max Sum(DP) Max Sum

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 244914    Accepted Submission(s): 57821

Problem Description Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
        

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6
        

给出n个数,求连续子串和的最大值,并记录起始点和终止点

直接遍历一遍,记录前缀和并不断刷新最大值和右端点,如果前缀和<0,将记录值变为0,左端点变为此时的下一点

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define inf 0x3f3f3f3f
#define mem(a,b) memset(a,b,sizeof(a))
#define N 100005
using namespace std;
int a[N];
int main()
{
    int t,q=1;
    scanf("%d",&t);
    while(t--)
    {
        int n;
       scanf("%d",&n);
       for(int i=1;i<=n;i++)
        scanf("%d",&a[i]);
       int cnt=0,maxn=-1000,x1=1,x,y;
       for(int i=1;i<=n;i++)
       {
           cnt+=a[i];
           if(cnt>maxn)
            maxn=cnt,x=x1,y=i;
           if(cnt<0)
            cnt=0,x1=i+1;
       }
       printf("Case %d:\n%d %d %d\n",q++,maxn,x,y);
       if(t)
        puts("");
    }
}