天天看点

POJ-1704 Georgia and Bob (阶梯博弈)

Georgia and Bob

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 7192 Accepted: 2157

Description

Georgia and Bob decide to play a self-invented game. They draw a row of grids on paper, number the grids from left to right by 1, 2, 3, ..., and place N chessmen on different grids, as shown in the following figure for example: 

POJ-1704 Georgia and Bob (阶梯博弈)

Georgia and Bob move the chessmen in turn. Every time a player will choose a chessman, and move it to the left without going over any other chessmen or across the left edge. The player can freely choose number of steps the chessman moves, with the constraint that the chessman must be moved at least ONE step and one grid can at most contains ONE single chessman. The player who cannot make a move loses the game. 

Georgia always plays first since "Lady first". Suppose that Georgia and Bob both do their best in the game, i.e., if one of them knows a way to win the game, he or she will be able to carry it out. 

Given the initial positions of the n chessmen, can you predict who will finally win the game? 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case contains two lines. The first line consists of one integer N (1 <= N <= 1000), indicating the number of chessmen. The second line contains N different integers P1, P2 ... Pn (1 <= Pi <= 10000), which are the initial positions of the n chessmen.

Output

For each test case, prints a single line, "Georgia will win", if Georgia will win the game; "Bob will win", if Bob will win the game; otherwise 'Not sure'.

Sample Input

2
3
1 2 3
8
1 5 6 7 9 12 14 17
      

Sample Output

Bob will win
Georgia will win      

思路:

      博弈论,阶梯博弈;

      阶梯博弈可转换为尼姆博弈求解,两个棋子之间的空格数即为每堆的石子数,偶数位置的石子实际不发挥任何作用,我们只需要关心奇数级台阶即可;

      资料:http://blog.csdn.net/longshuai0821/article/details/7793043

代码:

#include <stdio.h>
#include <algorithm>
using namespace std;

int t[1010], k[1010];

int main()
{
	int loop, n, i;
    scanf("%d", &loop);
    while (loop --){
        scanf("%d", &n);
        for (i = 0; i < n; i ++)
            scanf("%d", &t[i]);

        sort(t, t + n);
        for (i = n - 1; i >= 1; i --)
            k[i] = t[i] - t[i - 1] - 1;
		k[0] = t[0] - 1;

		int s = 0;
        for (i = n - 1; i >= 0; i -= 2)
			s ^= k[i];

        if(s)
			puts("Georgia will win");
        else
			puts("Bob will win");
    }

    return 0;
}