天天看点

poj 1458/ hdu 1159 Common SubsequenceCommon Subsequence

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 28520    Accepted Submission(s): 12748

Problem Description A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc abfcab
programming contest 
abcd mnp
        

Sample Output

4
2
0
  
  
   源代码
  
  
          
<span style="font-size:18px;">#include<cstdio>
#include<cstring>
#define max(a,b) (a>b?a:b)
char str1[1010],str2[1010];
int dp[1010][1010];
int len1,len2;

int main()
{
	while(scanf("%s%s",str1,str2)!=EOF)
	{
		memset(dp,0,sizeof(dp));
		len1=strlen(str1);
		len2=strlen(str2);
		for(int i=1;i<=len1;i++)
		{
			for(int j=1;j<=len2;j++)
			{
				if(str1[i-1]==str2[j-1])
					dp[i][j]=dp[i-1][j-1]+1;
				else
					dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
			}
		}
		printf("%d\n",dp[len1][len2]);
	}
	
	return 0;
}</span>
           
lcs模板

继续阅读