天天看点

HDU--1159 -- Common Subsequence [DP]Common Subsequence

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 17779 Accepted Submission(s): 7485

Problem Description A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc abfcab
programming contest 
abcd mnp
        

Sample Output

4
2
0
        

Code:

以第一个字符串的长度为行数,第二个字符串的长度为列数建立二维数组

如果第i个和第j个相等,则取a[i-1][j-1]+1,即左上角也就是前面序列的最优解加1

如果不相等,则取a[i-1][j]和a[i][j-1]的最大值,

状态方程为:

f(i,j)= f(i-1,j-1)+1   (a[i]==b[j])

f(i,j)=max(f(i-1,j),f(i,j-1))   (a[i]!=b[j])

以第一个sample input为例, 得二维数组如下,数组的右下方即为最终解

HDU--1159 -- Common Subsequence [DP]Common Subsequence
#include<stdio.h>
#include<string.h>
#define max(a,b) a>b?a:b
int a[1005][1005];
char str1[1005],str2[1005];
int main() 
{

    int len1,len2,i,j;
    while(scanf("%s%s",str1,str2)!=EOF)
    {
        len1 = strlen(str1); len2 = strlen(str2);
        memset(a,0,sizeof(a));
        for(i=0;i<len1;i++)
        {
            for(j=0;j<len2;j++)
            {
                if(str1[i]==str2[j]) a[i+1][j+1] = a[i][j] + 1;
                else a[i+1][j+1] = max(a[i][j+1],a[i+1][j]);
            }
        }
        printf("%d\n",a[len1][len2]); 
    }
    return 0;
}
           
ACM