天天看点

HDU-3033 I love sneakers! (多重背包 每组至少买一个) I love sneakers!

I love sneakers!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 5785    Accepted Submission(s): 2381

Problem Description After months of hard working, Iserlohn finally wins awesome amount of scholarship. As a great zealot of sneakers, he decides to spend all his money on them in a sneaker store.

HDU-3033 I love sneakers! (多重背包 每组至少买一个) I love sneakers!

There are several brands of sneakers that Iserlohn wants to collect, such as Air Jordan and Nike Pro. And each brand has released various products. For the reason that Iserlohn is definitely a sneaker-mania, he desires to buy at least one product for each brand.

Although the fixed price of each product has been labeled, Iserlohn sets values for each of them based on his own tendency. With handsome but limited money, he wants to maximize the total value of the shoes he is going to buy. Obviously, as a collector, he won’t buy the same product twice.

Now, Iserlohn needs you to help him find the best solution of his problem, which means to maximize the total value of the products he can buy.  

Input Input contains multiple test cases. Each test case begins with three integers 1<=N<=100 representing the total number of products, 1 <= M<= 10000 the money Iserlohn gets, and 1<=K<=10 representing the sneaker brands. The following N lines each represents a product with three positive integers 1<=a<=k, b and c, 0<=b,c<100000, meaning the brand’s number it belongs, the labeled price, and the value of this product. Process to End Of File.  

Output For each test case, print an integer which is the maximum total value of the sneakers that Iserlohn purchases. Print "Impossible" if Iserlohn's demands can’t be satisfied.  

Sample Input

5 10000 3
1 4 6
2 5 7
3 4 99
1 55 77
2 44 66
        

Sample Output

255
        
#include <bits/stdc++.h>
using namespace std;
int dp[101][10001];
vector<vector<int> > p(101), v(101); 
int main(){
	int n, m, k, a, b, c;
	while(scanf("%d %d %d", &n, &m, &k) != EOF){
		for(int i = 1; i <= k; ++i){
			p[i].clear();
			v[i].clear();
		}
		for(int i = 1; i <= n; ++i){
			scanf("%d %d %d", &a, &b, &c);
			p[a].push_back(b);
			v[a].push_back(c);
		}
		memset(dp, -1, sizeof(dp));
		for(int i = 0; i <= m; ++i){
			dp[0][i] = 0;
		}
		for(int i = 1; i <= k; ++i){
			for(int j = 0; j < p[i].size(); ++j){
				for(int s = m; s >= p[i][j]; --s){
					dp[i][s] = max(dp[i][s], dp[i][s - p[i][j]] + v[i][j]);  //p[i][j]可能为0,更新时注意顺序,很坑。。。。
					dp[i][s] = max(dp[i][s], dp[i - 1][s - p[i][j]] + v[i][j]);
				}
			}
		}
		if(dp[k][m] < 0){
			printf("Impossible\n");
		}
		else{
			printf("%d\n", dp[k][m]);
		}
	}
}

/*
题意:
100个物品,分为10组,10001的钱,每组最少买一个,问最多可以得到多少价值。

思路:
多重背包,加了一个条件是每组最少买一个。那么在更新答案的时候,分组遍历所有物品,对于某组物品,可能之前没有买过
该组的别的物品,可能已经买过,所有用dp[i][s - p[i][j]]和dp[i - 1][s - p[i][j]]去转移,前者是已经买过同组别的物品,
后者是没买过。总之考虑所有可能的状态就好。
*/