天天看点

POJ-2417 Baby-Step Giant-Step

Description

Given a prime P, 2 <= P < 2 ^ 31, an integer B, 2 <= B < P, and an integer N, 1 <= N < P, compute the discrete logarithm of N, base B, modulo P. That is, find an integer L such that B^L == N (mod P)

Input

Read several lines of input, each containing P,B,N separated by a space.

Output

For each line print the logarithm on a separate line. If there are several, print the smallest; if there is none, print “no solution”.

Sample Input

5 2 1

5 2 2

5 2 3

5 2 4

5 3 1

5 3 2

5 3 3

5 3 4

5 4 1

5 4 2

5 4 3

5 4 4

12345701 2 1111111

1111111121 65537 1111111111

Sample Output

1

3

2

3

1

2

no solution

no solution

1

9584351

462803587

Hint

The solution to this problem requires a well known result in number theory that is probably expected of you for Putnam but not ACM competitions. It is Fermat’s theorem that states B ^ (P-1) == 1 (mod P)

for any prime P and some other (fairly rare) numbers known as base-B pseudoprimes. A rarer subset of the base-B pseudoprimes, known as Carmichael numbers, are pseudoprimes for every base between 2 and P-1. A corollary to Fermat’s theorem is that for any m

B ^ (-m) == B ^ (P-1-m) (mod P) .

要求a,n互质

a ^ x = b (mod n)

x = m * i + j (m=ceil(sqrt(n)))

a ^ j = b * a ^ (-m * i)

j = 0 … m-1

#include<iostream>
#include<string.h>
#include<math.h>
using namespace std;
typedef long long ll;
const int mod=1e5+7;
int hs[mod],head[mod],nex[mod],id[mod],top;
void insert(int x,int y){
	int k=x%mod;
	hs[top]=x,id[top]=y,nex[top]=head[k],head[k]=top++;
}
int find(int x){
	int k=x%mod;
	for(int i=head[k];~i;i=nex[i])if(hs[i]==x)return id[i];
	return -1;
}
int BSGS(int a,int b,int n){
	if(b==1)return 0;
	memset(head,-1,sizeof(head));
	top=1;
	int m=sqrt(n*1.0),j;
	ll x=1,p=1;
	for(int i=0;i<m;++i,p=p*a%n)insert(p*b%n,i);
	for(ll i=m;;i+=m){
		if((j=find(x=x*p%n))!=-1)return i-j;
		if(i>n)break;
	}
	return -1;
}
int main(){
	int p,b,n;
	while(cin>>p>>b>>n){
		int ans=BSGS(b,n,p);
		if(~ans)cout<<ans<<endl;
		else cout<<"no solution\n";
	}
	return 0;
}