天天看點

PAT (Advanced Level) Practise 1046 Shortest Distance (20)

1046. Shortest Distance (20)

時間限制

100 ms

記憶體限制

65536 kB

代碼長度限制

16000 B

判題程式

Standard

作者

CHEN, Yue

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 ... DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9

3

1 3

2 5

4 1

Sample Output:

3

10

7

計算一下字首和,然後比較一下是直接走過去還是繞到n

#include<cstdio>    
#include<cstring>    
#include<cmath>    
#include<algorithm>    
#include<queue>    
using namespace std;
typedef long long ll;
const int maxn = 1e5 + 5;
int n, m, x, sum[maxn], y, k;

int main()
{
  scanf("%d", &n);
  for (int i = 2; i <= n; i++) scanf("%d", &x), sum[i] = sum[i - 1] + x;
  scanf("%d%d", &k, &m);
  while (m--)
  {
    scanf("%d%d", &x, &y);
    if (x > y) swap(x, y);
    printf("%d\n", min(sum[y] - sum[x], sum[x] + k + sum[n] - sum[y]));
  }
  return 0;
}