天天看點

POJ 2350 Above Average

Description

It is said that 90% of frosh expect to be above average in their class. You are to provide a reality check.

Input

The first line of standard input contains an integer C, the number of test cases. C data sets follow. Each data set begins with an integer, N, the number of people in the class (1 <= N <= 1000). N integers follow, separated by spaces or newlines, each giving the final grade (an integer between 0 and 100) of a student in the class.

Output

For each case you are to output a line giving the percentage of students whose grade is above average, rounded to 3 decimal places.

Sample Input

5

5 50 50 70 80 100

7 100 95 90 80 70 60 50

3 70 90 80

3 70 90 81

9 100 99 98 97 96 95 94 93 91

Sample Output

40.000%

57.143%

33.333%

66.667%

55.556%

#include <iostream>
#include <cstdlib>
#include <cstdio>
#include <cstring>
using namespace std;

#define maxn 1005

int n;
int f[maxn];
double average;

void input()
{
    int sum = 0;
    scanf("%d", &n);
    for (int i = 0; i < n; i++)
    {
        scanf("%d", &f[i]);
        sum += f[i];
    }
    average = sum * 1.0 / n;
}

double work()
{
    int num = 0;
    for (int i = 0; i < n; i++)
        if (f[i] > average)
            num++;
    return num * 100.0 / n;
}

int main()
{
    int t;
    scanf("%d", &t);
    while (t--)
    {
        input();
        printf("%.3f%%\n", work());
    }
    return 0;
}