天天看點

HDU 5366 The mook jong

Problem Description

HDU 5366 The mook jong

ZJiaQ want to become a strong man, so he decided to play the mook jong。ZJiaQ want to put some mook jongs in his backyard. His backyard consist of n bricks that is 1*1,so it is 1*n。ZJiaQ want to put a mook jong in a brick. because of the hands of the mook jong, the distance of two mook jongs should be equal or more than 2 bricks. Now ZJiaQ want to know how many ways can ZJiaQ put mook jongs legally(at least one mook jong).

Input

There ar multiply cases. For each case, there is a single integer n( 1 < = n < = 60)

Output

Print the ways in a single line for each case.

Sample Input

1

2

3

4

5

6

Sample Output

1

2

3

5

8

12

首先求出最後一個木樁放在第i個位置的方案數f[i]

#include<map>
#include<stack>
#include<queue>
#include<cmath>
#include<cstdio>
#include<vector>
#include<string>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn = 200005;
__int64 T, n, m, f[maxn], sum[maxn];

int main()
{
    //scanf("%d", &T);
    f[0] = f[1] = f[2] = 1;
    for (int i = 3; i <= 60;i++)
        for (int j = i - 3; j >= 0; j--) f[i] += f[j];
    for (int i = 1; i <= 60; i++)
        for (int j = 1; j <= i; j++) sum[i] += f[j];
    while (scanf("%I64d", &n) != EOF)
    {
        //scanf("%d%d", &n, &m);
        printf("%I64d\n", sum[n]);
    }
    return 0;
}           
上一篇: HDU 5367 digger