天天看點

PAT (Advanced Level) Practise 1007 Maximum Subsequence Sum (25)

1007. Maximum Subsequence Sum (25)

時間限制

400 ms

記憶體限制

65536 kB

代碼長度限制

16000 B

判題程式

Standard

作者

CHEN, Yue

Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21      

Sample Output:

10 1 4      

問一段連續子序列的最大和是多少,順便記錄下左端和右端

直接一遍掃描,對于和小于0的必然是不要的。

#include<cstdio>
#include<stack>
#include<cstring>
#include<string>
#include<algorithm>
#include<iostream>
using namespace std;
const int maxn = 1e5 + 10;
int n, l, r, a[maxn], flag, ans = -1;

int main()
{
  scanf("%d", &n);
  for (int i = 0; i < n; i++)
  {
    scanf("%d", &a[i]);
    if (a[i] >= 0) flag = 1;
  }
  if (!flag) printf("0 %d %d\n", a[0], a[n - 1]);
  else
  {
    for (int i = 0; i < n; i++)
    {
      int sum = 0, j;
      for (j = i; j < n; j++)
      {
        if ((sum += a[j]) < 0) break;
        if (sum>ans) { ans = sum; l = a[i]; r = a[j]; }
      }
      i = j;
    }
    printf("%d %d %d\n", ans, l, r);
  }
  
  return 0;
}