天天看點

PAT (Advanced Level) Practise 1016 Phone Bills (25)

1016. Phone Bills (25)

時間限制

400 ms

記憶體限制

65536 kB

代碼長度限制

16000 B

判題程式

Standard

作者

CHEN, Yue

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (<= 1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word "on-line" or "off-line".

For each test case, all dates will be within a single month. Each "on-line" record is paired with the chronologically next record for the same customer provided it is an "off-line" record. Any "on-line" records that are not paired with an "off-line" record are ignored, as are "off-line" records not paired with an "on-line" record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line      

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80      

算是比較惡心的模拟題了,用結構體存儲,按照名字和日期排序,然後先判斷是否有效,然後輸出,時間加減直接暴力即可

#include<cstdio>
#include<string>
#include<cstring>
#include<vector>
#include<iostream>
#include<queue>
#include<algorithm>
using namespace std;
typedef long long LL;
const int INF = 0x7FFFFFFF;
const int maxn = 1e3 + 10;
double f[maxn];
int n, x;
char ss[maxn];

struct point
{
  string s;
  int a, b, c, d, f;
  void read()
  {
    cin >> s;
    scanf("%d:%d:%d:%d", &a, &b, &c, &d);
    scanf("%s", ss);
    if (ss[1] == 'n') f = 0; else f = 1;
  }
  bool operator<(const point &x)const
  {
    return s == x.s ? a == x.a ? b == x.b ? c == x.c ? d < x.d : c < x.c : b < x.b : a < x.a : s < x.s;
  }
  bool operator==(const point &x)const
  {
    return b == x.b&&c == x.c&&d == x.d;
  }
}a[maxn];

double putout(point x, point y)
{
  double ans = 0;
  int cnt = 0;
  point u = x;
  while (true)
  {
    ans += f[u.c]; u.d += 1;  
    u.c += u.d / 60;  u.d %= 60;
    u.b += u.c / 24;  u.c %= 24;
    cnt++;  if (u == y) break;
  }
  printf("%02d:%02d:%02d %02d:%02d:%02d %d $%.2lf\n", x.b, x.c, x.d, y.b, y.c, y.d, cnt, ans);
  return ans;
}

int main()
{
  for (int i = 0; i < 24; i++) scanf("%d", &x), f[i] = x / 100.0;
  scanf("%d", &n);
  for (int i = 0; i < n; i++) a[i].read();
  sort(a, a + n);
  for (int i = 0, j; i < n; i = j)
  {
    int flag = 0, y = a[i].f;
    for (j = i + 1; a[j].s == a[i].s; j++)
    {
      if (!y&&a[j].f) { flag = 1; break; }
      else y = a[j].f;
    }
    if (flag)
    {
      cout << a[i].s;
      printf(" %02d\n", a[i].a);
      point x = a[i];
      double ans = 0;
      for (j = i + 1; a[j].s == a[i].s; j++)
      {
        if (!x.f && a[j].f) ans += putout(x, a[j]);
        x = a[j];
      }
      printf("Total amount: $%.2lf\n", ans);
    }
  }
  return 0;
}