天天看點

Count Color (線段樹,區間更新)

Problem Description

Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem.

There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment with only one color. We can do following two operations on the board:

1. "C A B C" Color the board from segment A to segment B with color C.

2. "P A B" Output the number of different colors painted between segment A and segment B (including).

In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the beginning, the board was painted in color 1. Now the rest of problem is left to your.

Input

First line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains "C A B C" or "P A B" (here A, B, C are integers, and A may be larger than B) as an operation defined previously.

Output

Ouput results of the output operation in order, each line contains a number.

Sample Input

2 2 4

C 1 1 2

P 1 2

C 2 2 2

P 1 2

Sample Output

2

1

題目大概:

在一個單行表格上,對他們進行區間塗色,最後查詢區間的顔色數。

思路:

線段樹,區間查詢,根據别人ac代碼寫的。

代碼:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

struct poin
{
    int l,r,id,v;
}a[101000<<2];

void build(int L,int R,int rt)
{
    a[rt].l=L;
    a[rt].r=R;
    if(L==R)return;
    int m=(L+R)>>1;
    build(L,m,rt<<1);
    build(m+1,R,rt<<1|1);

}
void update(int L,int R,int v,int rt)
{
    if(L==a[rt].l&&R==a[rt].r)
    {
        a[rt].id=1;
        a[rt].v=1<<(v-1);
        return;
    }
    if(a[rt].id)
    {
        a[rt].id=0;
        a[rt<<1].id=a[rt<<1|1].id=1;
        a[rt<<1].v=a[rt<<1|1].v=a[rt].v;
    }
    int m=(a[rt].l+a[rt].r)>>1;
    if(R<=m)
    {
        update(L,R,v,rt<<1);
    }
    else if(L>m)
    {
        update(L,R,v,rt<<1|1);
    }
    else
    {
        update(L,m,v,rt<<1);
        update(m+1,R,v,rt<<1|1);
    }
    a[rt].v=(a[rt<<1].v|a[rt<<1|1].v);
    if(a[rt<<1].id&&a[rt<<1|1].id&&a[rt<<1].v==a[rt<<1|1].v)
    a[rt].id=1;

}
int quert(int L,int R,int rt)
{
    if(a[rt].l==L&&a[rt].r==R)
    {
        return a[rt].v;
    }
    if(a[rt].id)
    {
        return a[rt].v;
    }
    int m=(a[rt].l+a[rt].r)>>1;
    if(R<=m)
    {
        return quert(L,R,rt<<1);
    }
    else if(L>m)
    {
        return quert(L,R,rt<<1|1);
    }
    else
    {
        return quert(L,m,rt<<1)|quert(m,R,rt<<1|1);
    }

}
int main()
{
    int l,k,n;
    while(~scanf("%d%d%d\n",&l,&k,&n))
    {


    build(1,l,1);
    a[1].v=1;
    a[1].id=1;
    while(n--)
    {
        char q[2];
        scanf("%s",q);
        if(q[0]=='C')
        {
            int w,e,r;
            scanf("%d%d%d",&w,&e,&r);
            update(w,e,r,1);
        }
        else
        {
            int w,e;
            scanf("%d%d",&w,&e);
            int sum=quert(w,e,1);
            int su=0;
            for(int j=0;j<k;j++)
            {
                if(sum&(1<<j))su++;
            }
            printf("%d\n",su);
        }

    }
    }
    return 0;
}