天天看點

杭電acm—1376 Octal Fractions 題目連結:http://acm.hdu.edu.cn/showproblem.php?pid=1376 Octal Fractions

題目連結:http://acm.hdu.edu.cn/showproblem.php?pid=1376

Octal Fractions

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 832    Accepted Submission(s): 386

Problem Description Fractions in octal (base 8) notation can be expressed exactly in decimal notation. For example, 0.75 in octal is 0.963125 (7/8 + 5/64) in decimal. All octal numbers of n digits to the right of the octal point can be expressed in no more than 3n decimal digits to the right of the decimal point.

Write a program to convert octal numerals between 0 and 1, inclusive, into equivalent decimal numerals. The input to your program will consist of octal numbers, one per line, to be converted. Each input number has the form 0.d1d2d3 ... dk, where the di are octal digits (0..7). There is no limit on k. Your output will consist of a sequence of lines of the form

0.d1d2d3 ... dk [8] = 0.D1D2D3 ... Dm [10]

where the left side is the input (in octal), and the right hand side the decimal (base 10) equivalent. There must be no trailing zeros, i.e. Dm is not equal to 0.

Sample Input

0.75
0.0001
0.01234567
        

Sample Output

0.75 [8] = 0.953125 [10]
0.0001 [8] = 0.000244140625 [10]
0.01234567 [8] = 0.020408093929290771484375 [10] 
        

Source South Africa 2001 這一道題目,苦思冥想了很久,最後得到同學的點撥,一語驚醒夢中人,抓住一點,double是可以把後面的小數點計算出來的,隻是輸出的時候沒有展現出來而已,是以,把小數點後的數字存儲到字元數組裡面就可以了。 AC代碼如下:(如有錯誤和建議,請同學們不吝指出)

#include<stdio.h>
#include<string.h>	
#include<math.h> 
char str[1000];
char str10[1000];
int main(){
	while(scanf("%s",str)!=EOF&&strcmp(str,"0")){
		int len=strlen(str);
		double sum=0;
		int k=1;
		for(int i=2;i<len;i++){
			sum+=(str[i]-'0')*1.0/pow(8,k++);
		}
		k=0;
		while(sum){//sum為0時退出 
			str10[k]=(int)(sum*10)%10+'0';//把小數點後的數字存到數組 
			sum=sum*10-(str10[k]-'0');//減去已存的數字 
			k++;
		}
		str10[k]='\0';//注意這個不可無 
		printf("%s [8] = 0.%s [10]\n",str,str10);
	}
	return 0;
}