天天看點

杭電acm-1005 Number Sequence

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 77210    Accepted Submission(s): 17999

Problem Description A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3
1 2 10
0 0 0
         

Sample Output

2
5
         

(1)遞歸,會導緻棧空間用盡; (2)循環,有時間限制 (3)分析下題目,可知道存在周期性,周期為49。先用一個數組儲存一個周期内所有值,用查表法求解

#include <stdio.h>
#include <stdlib.h>

unsigned int a, b, n,num[50];

int main(void)
{
    #if 1
        freopen("in.txt","r",stdin);
    #endif
    /*put your own code here*/
    unsigned int i;
    while(scanf( "%u %u %u", &a, &b, &n) && ((a || b || n) != 0))
    {
        for(i = 1; i < 50; i++)
        {
            if( i == 1 || i == 2)
                num[i] = 1;
            else
                num[i] = (a * num[i-1] + b * num[i-2]) % 7;
        }
        printf("%u\n", num[n%49]);
    }
    return 0;
}