天天看點

杭電acm:HDU 2700 ParityParity



Parity

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4762    Accepted Submission(s): 3579

Problem Description A bit string has odd parity if the number of 1's is odd. A bit string has even parity if the number of 1's is even.Zero is considered to be an even number, so a bit string with no 1's has even parity. Note that the number of

0's does not affect the parity of a bit string.  

Input The input consists of one or more strings, each on a line by itself, followed by a line containing only "#" that signals the end of the input. Each string contains 1–31 bits followed by either a lowercase letter 'e' or a lowercase letter 'o'.

Output Each line of output must look just like the corresponding line of input, except that the letter at the end is replaced by the correct bit so that the entire bit string has even parity (if the letter was 'e') or odd parity (if the letter was 'o').  

Sample Input

101e
010010o
1e
000e
110100101o
#
        

Sample Output

1010
0100101
11
0000
1101001010

   

   
   

   
   
    題意:
   
   
    輸入一串僅有0,1組成的數。數的最後以e或o結尾,以e結尾要求前面所有數中1的個數為偶數個,如果不是,将e改成1,輸出改過後的數。如果是,将e改成0,輸出改過後的數。以o結尾的數要求前面所有數中1的個數為奇數個,如果是,将o改成0,輸出改過後的數。如果不是,将o改成1,輸出改過後的數。
   
   

   
   
    思路:
   
   
    由題意可知e或o之前的數在輸入和輸出中是一樣的,是以對于e或o之前的數隻需要輸入一個就輸出一個即可。在輸入e或o時進行特殊考慮即可。最後i注意以下輸出格式,以及什麼時候輸入結束。
   
   

   
   
    代碼:
   
   
           
#include<bits/stdc++.h>

using namespace std;

int main()
{
        char c;
        int count_1=0;
        while(~scanf("%c",&c))
        {
                if(c=='#')
                        return 0;
                if(c=='1')
                {
                        count_1++;
                        cout << c;
                }
                if(c=='0')
                        cout << c;
                if(c=='e')
                {
                        if(count_1%2 == 0)
                                cout << '0' << endl;
                        else
                                cout << '1' << endl;
                        count_1=0;
                }
                if(c=='o')
                {
                        if(count_1%2==0)
                                cout << '1' << endl;
                        else
                                cout << '0' << endl;
                        count_1=0;
                }
        }
        return 0;
}
           
祝大家好運!