天天看點

1008. Elevator (20)題解1008. Elevator (20)

1008. Elevator (20)

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1
      

Sample Output:

41
      

這道題的幾乎沒有難度,單詞也很簡單。直接看代碼就好

#include <stdio.h>

int main()

{

int n;

  scanf("%d",&n);

  int now=0;//目前層數

  int time=0;//時間

  for(int i=0;i<n;i++)

  {

    int t;

  scanf("%d",&t);

    time+=5;//停留5秒

    if(t>now)time+=(t-now)*6;//如果上升,每一層加6秒

    else time+=(now-t)*4;//如果下降,每一層加4秒

    now=t;//停留到目前層

  }

  printf("%d",time);

}