天天看點

PAT (Advanced Level) Practise 1034 Head of a Gang (30)

1034. Head of a Gang (30)

時間限制

100 ms

記憶體限制

65536 kB

代碼長度限制

16000 B

判題程式

Standard

作者

CHEN, Yue

One way that the police finds the head of a gang is to check people's phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls made between the two persons. A "Gang" is a cluster of more than 2 persons who are related to each other with total relation weight being greater than a given threshold K. In each gang, the one with maximum total weight is the head. Now given a list of phone calls, you are supposed to find the gangs and the heads.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers N and K (both less than or equal to 1000), the number of phone calls and the weight threthold, respectively. Then N lines follow, each in the following format:

Name1 Name2 Time

where Name1 and Name2 are the names of people at the two ends of the call, and Time is the length of the call. A name is a string of three capital letters chosen from A-Z. A time length is a positive integer which is no more than 1000 minutes.

Output Specification:

For each test case, first print in a line the total number of gangs. Then for each gang, print in a line the name of the head and the total number of the members. It is guaranteed that the head is unique for each gang. The output must be sorted according to the alphabetical order of the names of the heads.

Sample Input 1:

8 59
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10      

Sample Output 1:

2
AAA 3
GGG 3      

Sample Input 2:

8 70
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10      

Sample Output 2:

先用并查集來合并,然後統計一下各個連通塊的總和,排序輸出。

#include<cstdio>
#include<vector>
#include<map>
#include<queue>
#include<string>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int INF = 0x7FFFFFFF;
const int maxn = 2e3 + 10;
int n, k, fa[maxn], cnt[maxn], tot, z;
int x[maxn], y[maxn], sum[maxn], p[maxn];
string s, t, w[maxn];
vector<string> ans;
map<string, int> M;

int get(int x)
{
  return x == fa[x] ? x : fa[x] = get(fa[x]);
}

int main()
{
  scanf("%d%d", &n, &k);
  for (int i = 0; i < n + n; i++) fa[i] = i;
  for (int i = 0; i < n; i++)
  {
    cin >> s >> t >> z;
    if (!M[s]) w[++tot] = s, M[s] = tot;
    if (!M[t]) w[++tot] = t, M[t] = tot;
    x[i] = M[s];  y[i] = M[t];
    cnt[x[i]] += z; cnt[y[i]] += z;
  }
  for (int i = 0; i < n; i++)
  {
    int fx = get(x[i]), fy = get(y[i]);
    if (fx == fy) continue;
    if (cnt[fx]>cnt[fy]) fa[fy] = fx;
    else fa[fx] = fy;
  }
  for (int i = 1; i <= tot; i++) fa[i] = get(i), sum[fa[i]] += cnt[i], p[fa[i]]++;
  for (int i = 1; i <= tot; i++) if (sum[i] > 2*k&&p[i]>2) ans.push_back(w[i]);
  sort(ans.begin(), ans.end());
  printf("%d\n", ans.size());
  if (ans.size())
  {
    for (int i = 0; i < ans.size(); i++)
    {
      cout << ans[i] << " " << p[M[ans[i]]] << endl;
    }
  }
  return 0;
}