天天看點

FZU Problem 2221 RunningMan

Accept: 840    Submit: 2574

Time Limit: 1000 mSec    Memory Limit : 32768 KB

Problem Description

ZB loves watching RunningMan! There's a game in RunningMan called 100 vs 100.

There are two teams, each of many people. There are 3 rounds of fighting, in each round the two teams send some people to fight. In each round, whichever team sends more people wins, and if the two teams send the same amount of people, RunningMan team wins. Each person can be sent out to only one round. The team wins 2 rounds win the whole game. Note, the arrangement of the fighter in three rounds must be decided before the whole game starts.

We know that there are N people on the RunningMan team, and that there are M people on the opposite team. Now zb wants to know whether there exists an arrangement of people for the RunningMan team so that they can always win, no matter how the opposite team arrange their people.

Input

The first line contains an integer T, meaning the number of the cases. 1 <= T <= 50.

For each test case, there's one line consists of two integers N and M. (1 <= N, M <= 10^9).

Output

For each test case, Output "Yes" if there exists an arrangement of people so that the RunningMan team can always win. "No" if there isn't such an arrangement. (Without the quotation marks.)

Sample Input

2100 100200 100

Sample Output

NoYes 

雖然是到水題,但在當時也讓我們想了很久....

AC代碼:

#include<cstdio>
int main() 
{
  int t,n,m;
  scanf("%d",&t);
  while(t--)
  {
    scanf("%d %d",&n,&m);
    if((n+1)/3>=m/2)  puts("Yes");
    else        puts("No");
  }
  return 0;
}