天天看點

【HDU - 1059 Dividing】 混合背包

I - Dividing

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. 

Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles. 

Input

Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000. 

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line. 

Output

For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''. 

Output a blank line after each test case. 

Sample Input

1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0      

Sample Output

Collection #1:
Can't be divided.

Collection #2:
Can be divided.      

題意:有價值分别為1~6的大理石,現要将這些大理石分為價值相等的兩部分,輸出是否可實作分離。

分析:一個裸的混合背包問題。在做背包之前先判斷大理石的總價值sum是否為奇數,若為奇數直接判斷無法分離。若是偶數則将總價值sum /= 2,以sum值作為背包容量。最後判斷dp[sum]是否等于sum,若等于則可分離,否則無法分離。

代碼如下:

#include <set>
#include <map>
#include <queue>
#include <cmath>
#include <vector>
#include <cctype>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define mod 835672545
#define INF 0x3f3f3f3f
#define LL long long
using namespace std;
const int MX = 120005;
int n, m;
int sum;
int a[10];
int dp[MX];
void zeroOnePack(int v){
    for(int i = sum; i >= v; i--){
        dp[i] = max(dp[i], dp[i-v] + v);
    }
}
void completePack(int v){
    for(int i = v; i <= sum; i++){
        dp[i] = max(dp[i], dp[i-v] + v);
    }
}
void mutiPack(int v, int w){
    if(v * w >= sum){
        completePack(v);
        return ;
    }
    int k = 1;
    while(k < w){
        zeroOnePack(k*v);
        w -= k;
        k <<= 1;
    }
    zeroOnePack(w*v);
}
int main(){
    int cas = 0;
    while(~scanf("%d", &a[1])){
        memset(dp, 0, sizeof(dp));
        sum = a[1];
        for(int i = 2; i <= 6; i++){
            scanf("%d", &a[i]);
            sum += a[i]*i;
        }
        if(a[1] + a[2] + a[3] + a[4] + a[5] + a[6] == 0)    return 0;
        printf("Collection #%d:\n", ++cas);
        if(sum & 1){
            printf("Can't be divided.\n\n");
            continue;
        }
        sum /= 2;
        for(int i = 1; i <= 6; i++){
            mutiPack(i, a[i]);
        }
        if(dp[sum] == sum)   printf("Can be divided.\n\n");
        else    printf("Can't be divided.\n\n");
    }
    return 0;
}