天天看點

HDU5120 Intersection(求兩圓環相交) Intersection

Intersection

Time Limit: 4000/4000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)Total Submission(s): 3178    Accepted Submission(s): 1203 Problem Description Matt is a big fan of logo design. Recently he falls in love with logo made up by rings. The following figures are some famous examples you may know.

HDU5120 Intersection(求兩圓環相交) Intersection

A ring is a 2-D figure bounded by two circles sharing the common center. The radius for these circles are denoted by r and R (r < R). For more details, refer to the gray part in the illustration below.

HDU5120 Intersection(求兩圓環相交) Intersection

Matt just designed a new logo consisting of two rings with the same size in the 2-D plane. For his interests, Matt would like to know the area of the intersection of these two rings.   Input The first line contains only one integer T (T ≤ 10 5), which indicates the number of test cases. For each test case, the first line contains two integers r, R (0 ≤ r < R ≤ 10).Each of the following two lines contains two integers x i, y i (0 ≤ x i, y i ≤ 20) indicating the coordinates of the center of each ring.   Output For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y is the area of intersection rounded to 6 decimal places.   Sample Input

2
2 3
0 0
0 0
2 3
0 0
5 0
         

  Sample Output

Case #1: 15.707963
Case #2: 2.250778
          

  題意:給你圓環的内半徑和外半徑,再給你兩個圓環(圓環相同)的中點坐标,求兩個圓環重合的面積 思路:先畫個圖,由圖可知黑色部分為相交的面積,将一個圓環分解成一個小圓和一個大圓,用area表示兩個圓相交的面積,那麼黑色部分面積就是area(A,B)-area(A,b)-area(B,a)+area(a,b)

HDU5120 Intersection(求兩圓環相交) Intersection

隻用寫一個兩個圓相交面積的函數即可

#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#define PI 3.14159265357
struct circle
{
    double x,y;
    double r;
};
double dis(circle a,circle b)
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
double solve(circle a, circle b) {
    double d = dis(a, b);
    if (d >= a.r + b.r)
        return 0;
    if (d <= fabs(a.r - b.r)) {
        double r = a.r < b.r ? a.r : b.r;
        return PI * r * r;
    }
    double ang1 = acos((a.r * a.r + d * d - b.r * b.r) / 2. / a.r / d);
    double ang2 = acos((b.r * b.r + d * d - a.r * a.r) / 2. / b.r / d);
    double ret = ang1 * a.r * a.r + ang2 * b.r * b.r - d * a.r * sin(ang1);
    return ret;
}
int main()
{
    circle a,b,A,B;
    double r,R;
    int t,cas=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf%lf",&r,&R);
        a.r=b.r=r;
        A.r=B.r=R;
        scanf("%lf%lf%lf%lf",&a.x,&a.y,&b.x,&b.y);
        A.x=a.x;
        A.y=a.y;
        B.x=b.x;
        B.y=b.y;
        printf("Case #%d: ",cas++);
        double area=solve(A,B)-solve(A,b)-solve(B,a)+solve(a,b);
        printf("%lf\n",area);
    }
    return 0;
}