1053 Path of Equal Weight (30 分)
Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.
Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<230, the given weight number. The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:
where
ID
is a two-digit number representing a given non-leaf node,
K
is the number of its children, followed by a sequence of two-digit
ID
's of its children. For the sake of simplicity, let us fix the root ID to be
00
.
Output Specification:
For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.
Note: sequence {A1,A2,⋯,An} is said to be greater than sequence {B1,B2,⋯,Bm} if there exists 1≤k<min{n,m} such that Ai=Bi for i=1,⋯,k, and Ak+1>Bk+1.
Sample Input:
Sample Output:
題目大意:
給出有n個結點的樹以及m個非葉子結點以及目标值,下一行便是n個結點的權重,随後是m行,關于結點I 與 k個孩子編号。
輸出權重從大到小序列。
思路:
用dfs+領接表,并且錄入某結點的所有孩子結點時,讓權重大的結點排到前面。在dfs中遇到總值達到目标時就可輸出了。
參考代碼:
#include<vector>
#include<cstdio>
#include<algorithm>
using namespace std;
vector<vector<int> > e;
vector<int> w, ans;
int n, m, s;
bool cmp(int a, int b){return w[a] > w[b];}
void dfs(int v, int weight){
if(weight > s) return;
ans.push_back(w[v]);
if(weight == s && !e[v].size())
for(int i = 0; i < ans.size(); ++i) printf("%d%c", ans[i], i != ans.size() - 1? ' ':'\n');
for(int i = 0; i < e[v].size(); ++i)
dfs(e[v][i], weight + w[e[v][i]]);
ans.pop_back();
}
int main(){
scanf("%d%d%d", &n, &m, &s);
w.resize(n), e.resize(n);
for(int i = 0; i < n; ++i) scanf("%d", &w[i]);
for(int i = 0; i < m; ++i){
int idx, k;
scanf("%d%d", &idx, &k);
e[idx].resize(k);
for(int j = 0; j < k; ++j) scanf("%d", &e[idx][j]);
sort(e[idx].begin(), e[idx].end(), cmp);
}
dfs(0, w[0]);
return 0;
}