題目
1053 Path of Equal Weight (30分)
Given a non-empty tree with root R, and with weight W**i assigned to each tree node T**i. The weight of a path from *R* to *L* is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.
Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let’s consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<230, the given weight number. The next line contains N positive numbers where W**i (<1000) corresponds to the tree node T**i. Then M lines follow, each in the format:
ID K ID[1] ID[2] ... ID[K]
where
ID
is a two-digit number representing a given non-leaf node,
K
is the number of its children, followed by a sequence of two-digit
ID
's of its children. For the sake of simplicity, let us fix the root ID to be
00
.
Output Specification:
For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.
Note: sequence { A 1 , A 2 , ⋯ , A n A_1,A_2,⋯,A_n A1,A2,⋯,An} is said to be greater than sequence { B 1 , B 2 , ⋯ , B m B_1,B_2,⋯,B_m B1,B2,⋯,Bm} if there exists 1≤k< min { n , m } \min \{n,m\} min{n,m} such that A i = B i A_i=B_i Ai=Bi for i=1,⋯,k, and A k A_k Ak+1> B k B_k Bk+1.
Sample Input:
20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19
Sample Output:
10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2
題目大意
給出一棵非空的樹,根結點ID為00, 每個結點都有其權重, 根結點為R, 從R到葉子結點L的路徑的權重等于路徑上的所有點的權重之和;
輸入:給出樹的結點個數N, 非葉子結點個數M,表示權重之和的數S,接下來一行N個數表示每個結點的權重,接下來M行每行給出非葉子結點的id, 孩子個數,孩子id,
要求:找到所有路徑,使得每條路徑權重之和為S,輸出根結點到葉子結點的路徑的權重序列,按權重序列降序輸出
思路
因為要求每條路徑的排列為按結點權重降序輸出,故可以在剛開始的時候對父結點的子結點序列按權重降序排序,利用DFS來找路徑即可
代碼
#include<bits/stdc++.h>
using namespace std;
struct node{
int id, weight;
};
vector<int> weight;
vector<vector<node> > tree;
vector<int> path;
vector<vector<int> > allPaths;
int N, M, S, K, id, child;
void dfs(int v){
path.push_back(v);
if(tree[v].size() == 0){ // 葉子結點
int sum = 0;
for(int i=0; i<path.size(); i++){
sum += weight[path[i]];
}
if(sum == S){
allPaths.push_back(path);
}
path.pop_back();
return;
}
for(auto it : tree[v])
dfs(it.id);
path.pop_back();
}
int main(int argc, const char * argv[]) {
scanf("%d%d%d",&N, &M, &S);
weight.resize(N);
tree.resize(N);
for(int i=0; i<N; i++)
cin>>weight[i];
for(int i=0; i<M; i++){
scanf("%d%d",&id, &K);
for(int j=0; j<K; j++){
scanf("%d", &child);
tree[id].push_back({child, weight[child]});
}
sort(tree[id].begin(), tree[id].end(), [](const node& a, const node& b){
return a.weight > b.weight;
});
}
dfs(0);
for(int i=0; i<allPaths.size(); i++){
for(int j=0; j<allPaths[i].size(); j++)
printf("%s%d", j==0 ? "" : " ", weight[allPaths[i][j]]);
printf("\n");
}
return 0;
}